4 Replies Latest reply on Sep 10, 2010 7:01 AM by sstone1024

    Problem with new Safari version (or flash version?) 5x

    DDev_sw

      Hi,

       

      I've got some annoying problem with my flex application (backend coldfusion, remoting over flex2gateway) and the new Safari 5. In the old version 4 it works fine!

       

      The error I get, by calling Remote calls over the flex2gateway is as follow: "Send failed"

       

      with this error stack:

      ------------------------------------------------------------------------------------------ ---------------------------------------

      (mx.rpc::Fault)#0

       

        content = (Object)#1

       

        errorID = 0

       

        faultCode = "Client.Error.MessageSend"

       

        faultDetail = "Channel.Ping.Failed error null url: '<domain>/flex2gateway/'"

       

        faultString = "Send failed"

       

        message = "faultCode:Client.Error.MessageSend faultString:'Send failed' faultDetail:'Channel.Ping.Failed error null url: '<domain>/flex2gateway/''"

       

        name = "Error"

       

        rootCause = (mx.messaging.events::ChannelFaultEvent)#2

       

          bubbles = false

       

          cancelable = false

       

          channel = (mx.messaging.channels::AMFChannel)#3

       

            authenticated = false

       

            channelSets = (Array)#4

       

              [0] (mx.messaging::ChannelSet)#5

       

                authenticated = false

       

                channelIds = (Array)#6

       

                  [0] (null)

       

                channels = (Array)#7

       

                  [0] (mx.messaging.channels::AMFChannel)#3

       

                clustered = false

       

                connected = false

       

                currentChannel = (mx.messaging.channels::AMFChannel)#3

       

                initialDestinationId = (null)

       

                messageAgents = (Array)#8

       

                  [0] (mx.rpc::AsyncRequest)#9

       

                    authenticated = false

       

                    autoConnect = true

       

                    channelSet = (mx.messaging::ChannelSet)#5

       

                    clientId = (null)

       

                    connected = false

       

                    defaultHeaders = (null)

       

                    destination = "ColdFusion"

       

                    id = "7938EA63-3CE1-A06C-0ED5-563528D4C0C5"

       

                    reconnectAttempts = 0

       

                    reconnectInterval = 0

       

                    requestTimeout = -1

       

                    subtopic = ""

       

            connected = false

       

            connectTimeout = -1

       

            enableSmallMessages = true

       

            endpoint = "<domain>/flex2gateway/"

       

            failoverURIs = (Array)#10

       

            id = (null)

       

            mpiEnabled = false

       

            netConnection = (flash.net::NetConnection)#11

       

              client = (mx.messaging.channels::AMFChannel)#3

       

              connected = false

       

              objectEncoding = 3

       

              proxyType = "none"

       

              uri = "<domain>/flex2gateway/"

       

            piggybackingEnabled = false

       

            polling = false

       

            pollingEnabled = true

       

            pollingInterval = 3000

       

            protocol = "http"

       

            reconnecting = false

       

            recordMessageSizes = false

       

            recordMessageTimes = false

       

            requestTimeout = -1

       

            uri = "<domain>/flex2gateway/"

       

            url = "<domain>/flex2gateway/"

       

            useSmallMessages = false

       

          channelId = (null)

       

          connected = false

       

          currentTarget = (mx.messaging.channels::AMFChannel)#3

       

          eventPhase = 2

       

          faultCode = "Channel.Ping.Failed"

       

          faultDetail = "null url: '<domain>/flex2gateway/'"

       

          faultString = "error"

       

          reconnecting = false

       

          rejected = false

       

          rootCause = (mx.messaging.messages::ErrorMessage)#12

       

            body = (null)

       

            clientId = (null)

       

            correlationId = "067A6FB7-FA83-F457-1E33-563529360B9F"

       

            destination = ""

       

            extendedData = (null)

       

            faultCode = "Server.Processing.DuplicateSessionDetected"

       

            faultDetail = (null)

       

            faultString = "Detected duplicate HTTP-based FlexSessions, generally due to the remote host disabling session cookies. Session cookies must be enabled to manage the client connection correctly."

       

            headers = (Object)#13

       

            messageId = "5C77A4AF-B61C-C1A1-2974-81CED927A6D0"

       

            rootCause = (null)

       

            timestamp = 1281346574870

       

            timeToLive = 0

       

          target = (mx.messaging.channels::AMFChannel)#3

       

          type = "channelFault"

      ------------------------------------------------------------------------------------------ ----------------------------------------------

       

      The clue is, that this problem is really just on the safari 5 (no different on which os) version... in all other browsers the app is running fine.

       

      Has anybody an idea what the problem is or how to solve this issue?

       

      thanks alot!

       

      best regards

      Thomas