4 Replies Latest reply on Aug 12, 2010 8:43 AM by 1972DanaT

    RoboHelp 8 Related Topics hyperlinks now underlined inconsistently in WebHelp output

    1972DanaT

      I recently upgraded to Robohelp HTML 8.0.2.208 from RoboHelp HTML 7.x and I use the WebHelp output.

       

      Without having to tell customers (this is a last resort) to enable the IE 8 setting "Display All Websites in Compatibility View," does anyone have any idea how to prevent the Related Topics' links from being underlined with inconsistent colors? Am I missing where the related topics' formats are underlined? Also, my drop-down text within topics is inconsistently underlined (some drop-down text links are underlined, which is my preference, and some are not).

       

      Formerly, my Related Topics' hyperlinks looked like:

      Robo7Relatedtopics.jpg

       

      Now, the Related Topics design-time control in the Compiled WebHelp now looks like:

      Robo8RelatedTopics.jpg

      My RoboHelp 8 HTML code:

       

      <!--Metadata type="DesignerControl" startspan
      <object classid="clsid:FF80F713-5DC6-11d0-A7B4-00AADC53E937">
      <param name="_Version" value="65536"  />
      <param name="_ExtentX" value="2032"  />
      <param name="_ExtentY" value="423"  />
      <param name="_StockProps" value="13"  />
      <param name="ForeColor" value="0"  />
      <param name="BackColor" value="14215660"  />
      <param name="UseButton" value="-1"  />
      <param name="UseText" value="0"  />
      <param name="ControlLabel" value="Related Topics"  />
      <param name="UseIcon" value="-1"  />
      <param name="Items" value="Document Access Report;Document_Access_Report.htm$$**$$PaperVision Enterprise Reports;Working_with_reports.htm$$**$$System Operations Report;System_Operations_Report.htm$$**$$Utilization Report;Utilization_reports.htm$$**$$Workflow History Report;Workflow_History_Report.htm$$**$$Workflow Status Report;Workflow_Status_Report.htm$$**$$"
        />
      <param name="Image" value="relatedtopicsGREEN.bmp"  />
      <param name="FontInfo" value="Microsoft Sans Serif,8,0,,"  />
      <param name="_CURRENTFILEPATH" value="C:\RoboHelp Test\RoboHelp Working Files\Archived_Reports.htm"
        />
      <param name="_ID" value=""  />
      <param name="UseMenu" value="-1"  />
      <param name="Frame" value=""  />
      <param name="Window" value=""  />
      </object>--><object
        classid="clsid:ADB880A6-D8FF-11CF-9377-00AA003B7A11"
          type="application/x-oleobject" >
        <param  name="Command"  value="Related Topics,MENU" />
        <param  name="Button"  value="Bitmap:relatedtopicsGREEN.bmp" />
        <param  name="Font"  value="Microsoft Sans Serif,8,0,," />
        <param  name="Item1"  value="Document Access Report;Document_Access_Report.htm" />
        <param  name="Item2"  value="PaperVision Enterprise Reports;Working_with_reports.htm" />
        <param  name="Item3"  value="System Operations Report;System_Operations_Report.htm" />
        <param  name="Item4"  value="Utilization Report;Utilization_reports.htm" />
        <param  name="Item5"  value="Workflow History Report;Workflow_History_Report.htm" />
        <param  name="Item6"  value="Workflow Status Report;Workflow_Status_Report.htm" />
      </object>
      <!--Metadata type="DesignerControl" endspan-->

       

      Any suggestions are appreciated.

        • 1. Re: RoboHelp 8 Related Topics hyperlinks now underlined inconsistently in WebHelp output
          Peter Grainge Adobe Community Professional (Moderator)

          Set up a simple test in a new project using the default CSS and see if things are consistent there.

           

          If they are, then I suspect some inline styling is coming into play. Post back after you have checked that out.

           


          See www.grainge.org for RoboHelp and Authoring tips

           

          @petergrainge

          • 2. Re: RoboHelp 8 Related Topics hyperlinks now underlined inconsistently in WebHelp output
            James K. Patrick

            1972DanaT,

             

            I had the opposite problem - inconsistent underlines in Firefox. I simply controled them in CSS:

             

            /* Display "Related Topics" link in FF without the default underline */
            a[title=" Related Topics"] {
                text-decoration: none;
            }
            /* Display "Related Topics" popup without intermittent underline in FF */   
            div#PopupMenu a {
                text-decoration: none;
            }

             

            Patrick

            • 3. Re: RoboHelp 8 Related Topics hyperlinks now underlined inconsistently in WebHelp output
              1972DanaT Level 1

              Peter, I set up a simple WebHelp project and the same thing happened with inconsistent underline colors when viewing in IE8:

              WebHelpTest.jpg

              The HTML code for the Related Topics Design-Time Control:
              <!--Metadata type="DesignerControl" startspan
              <object classid="clsid:FF80F713-5DC6-11d0-A7B4-00AADC53E937">
              <param name="_Version" value="65536"  />
              <param name="_ExtentX" value="2138"  />
              <param name="_ExtentY" value="508"  />
              <param name="_StockProps" value="13"  />
              <param name="ForeColor" value="0"  />
              <param name="BackColor" value="15790320"  />
              <param name="UseButton" value="1"  />
              <param name="UseText" value="0"  />
              <param name="ControlLabel" value="Related Topics"  />
              <param name="UseIcon" value="0"  />
              <param name="Items" value="Test1;Test1.htm$$**$$Test2;Test2.htm$$**$$Test3;Test3.htm$$**$$"
                />
              <param name="Image" value=""  />
              <param name="FontInfo" value="Microsoft Sans Serif,8,0,,"  />
              <param name="_CURRENTFILEPATH" value="C:\WebHelpTest\WebHelp_Test\Intro.htm"
                />
              <param name="_ID" value=""  />
              <param name="UseMenu" value="1"  />
              <param name="Frame" value=""  />
              <param name="Window" value=""  />
              </object>-->
              <object
                classid="clsid:ADB880A6-D8FF-11CF-9377-00AA003B7A11"
                  type="application/x-oleobject" >
                <param  name="Command"  value="Related Topics,MENU" />
                <param  name="Button"  value="Text:Related Topics" />
                <param  name="Font"  value="Microsoft Sans Serif,8,0,," />
                <param  name="Item1"  value="Test1;Test1.htm" />
                <param  name="Item2"  value="Test2;Test2.htm" />
                <param  name="Item3"  value="Test3;Test3.htm" />
              </object>

              <!--Metadata type="DesignerControl" endspan-->

               

              • 4. Re: RoboHelp 8 Related Topics hyperlinks now underlined inconsistently in WebHelp output
                1972DanaT Level 1

                Thanks, Patrick - that did the trick for intermittent colors/underlines in the popup within the Related Topics' design-time control.  Next, I'll try to fix the inconsistency in the drop-down text:

                WebHelp Dropdown text.jpg

                --Dana