This content has been marked as final. Show 6 replies
It's always a personal preference but I go since I started with AS3, I now go with _bool:Boolean. It doesn't get much more generic than that.
I like "boolVar" or "boolVal". Sometimes, I also use "flag" or "bit" if
the usage is more specific.
> I know it is a silly question, but I haven't come up with a good name for a
> generic Boolean variable in a function signature. So for example if I've got
> some function that will receive a movieclip or something I usually do it like
> one of the following:
> Or some such. For a String I usually use str, for a Number, num or x or val,
> and I pretty much have a name for everything except Booleans. So what do all
> y'all call them and why?
Faster, easier, better...ActionScript development taken to new heights.
Download the BNMAPI today. You'll wonder how you ever did without it!
Available for ActionScript 2.0/3.0.
> For a String I usually use str, for a Number, num or x or val
Heh, interesting ... yeah, I often use str, and for numbers, num, x, or
> I pretty much have a name for everything except Booleans.
> So what do all y'all call them and why?
Ehh ... flag or b -- mainly because they're short. ;)
Adobe Community Expert
Dev blog, http://www.quip.net/blog/
"Luck is the residue of good design."
booLean. why? it's just easy that way. and it gives me a laugh some time saying it in my head, boo-lean
i use someNameBool.
Cool. So it would seem there are many ways to go. Now I'll just have to think about which I like best. Thanks everybody for the ideas.