6 Replies Latest reply on Jan 3, 2014 7:36 AM by hissizadam

    Problem to connect New Flex project to a generic Zend-Framework Folder

    juedvaga80

      Good morning to all

      I have a problem now to connect a new Flex proyect.
      The error is:

      ////////////////////////////////////////////////// ////////////////////////////////////////////////// //////////////////
      Make  sure That Zend Framework is installed CORRECTLY and the parameter  "amf.production" is not set to true in the file amf_config.ini Located  in the project output folder.
      Warning:  include_once (EmployeeService.php) [function.include-once]: failed to  open stream: No such file or directory in C: \ wamp \ www \  ZendFramework \ library \ Zend \ Loader.php on line 135

      Warning:  include_once () [function.include]: Failed opening  'EmployeeService.php' for inclusion (include_path = 'C: / wamp / www /  TestDrive-debug / services \.;.; C: \ php5 \ pear; C: \ wamp \ www \ ZendFramework \ library ') in C: \ wamp \ www \ ZendFramework \ library \ Zend \ Loader.php on line 135
      ? /  0/onStatusÿÿÿÿ? SIflex.messaging.messages.ErrorMessage? ExtendedData?  FaultCode? FaultDetail? FaultString? RootCause? CorrelationId? Customer?  Destination? MESSAGE? Timestamp? TimeToLive? Body headers ???{# 0 C: \  wamp \ www  \ ZendFramework \ library \ Zend \ Amf \ Adobe \ Introspector.php (96):  Zend_Loader:: loadClass ('EmployeeService', Array) # 1 [internal  function]: Zend_Amf_Adobe_Introspector-> introspect  ('EmployeeService', Array) # 2 [internal  function]: ReflectionMethod-> invokeArgs (Object  (Zend_Amf_Adobe_Introspector), Array) # 3 C: \ wamp \ www \  ZendFramework \ library \ Zend \ Server \ Reflection \ Function \  Abstract.php (368): call_user_func_array (Array, Array )  # 4 [internal function]: Zend_Server_Reflection_Function_Abstract->  __call ('invokeArgs', Array) # 5 C: \ wamp \ www \ ZendFramework \  library \ Zend \ Amf \ server.php (356):  Zend_Server_Reflection_Method-> invokeArgs (Object ( Zend_Amf_Adobe_Introspector),  Array) # 6 C: \ wamp \ www \ ZendFramework \ library \ Zend \ Amf \  server.php (550): Zend_Amf_Server-> _dispatch ('introspect', Array,  'Zend_Amf_Adobe_ ...')# 7 C :  \ wamp \ www \ ZendFramework \ library \ Zend \ Amf \ server.php (626):  Zend_Amf_Server-> _handle (Object (Zend_Amf_Request_Http)) # 8 C: \  wamp \ www \ internet \ TestDrive-debug \ gateway.php ( 69):  Zend_Amf_Server-> handle () # 9 (main)? = File "EmployeeService.php"  does not exist or class "EmployeeService" was not found in the file?  I8F6731CA-910E-6613-0548-A83E869D9423? I2A06F7A2 -5BC9-4409-334B-00001024FFE6? I2C7AEEDF-FEB2-0AA9-AA32-00005451AE49? 128 169 660 200 begin_of_the_skype_highlighting              128 169 660 200     end_of_the_skype_highlighting? ??
      ////////////////////////////////////////////////// ////////////////////////////////////////////////// //////////////////

      I modified the file: amf_config.ini to recognize the path where is Zend-Framwork
      The file has now contains this:

      ////////////////////////////////////////////////// ////////////////////////////////////////////////// //////////////////
      [Zend]
      ; September the absolute location path of webroot directory, example:
      ; Windows: C: \ apache \ www
      ; MAC / UNIX: / user / apache / www
      webroot = C: / wamp / www

      ; September the absolute location path of zend installation directory, example:
      ; Windows: C: \ apache \ PHPFrameworks \ ZendFramework \ library
      ; MAC / UNIX: / user / apache / PHPFrameworks / ZendFramework / library
      zend_path = C: \ wamp \ www \ ZendFramework \ library

      [Zendamf]
      amf.production = false
      amf.directories [] = TestDriver-debug/services
      ////////////////////////////////////////////////// ////////////////////////////////////////////////// //////////////////

       

      Attach the configuration file:  http://www.megaupload.com/?d=RM62CRHT

       

       

      Does any body have an idea how to correct this please.

      Thanks.