8 Replies Latest reply on Jul 30, 2007 8:42 AM by Newsgroup_User

    DW acting strange - does not go to code view

    corradoconti
      My Dreamweaver CS3 has started acting strangely since I upgraded to a new version of CS3 studio.
      I have been working with CS3 for a while now without needing too much of an adjustment from DW8.
      However, I just bought a new computer so I had to reinstall all my software.


      On the new box, DW is acting mighty strange:

      1) When I am in Layout view and click on an element to go to the corresponding line of code for the element it no longer goes to the line. However, it does when I r-click on it. It is a bit annoying since it also opens the contextual menu at the same time.

      2) When I am in code view (which is 99% of the time) and I click on an element, it no longer shows me the corresponding CSS rule in the CSS pane. Again, if I r-click sometiomes it works, but this one is not reliable either way. Sometimes it works if I double click, but most of the time it doesn't.


      3) The comment icon on the code toolbar is often grayed out. No reason I can see and just as often it wil work on the same line of code where it didn't work a minute before.

      I combed the preferences line by line without success.
      On my old computer I never had any issues like this. I find it very strange and it is crimping my workflow considerably. Is anyone familiar with theis behavior or how to fix it?
        • 1. Re: DW acting strange - does not go to code view
          DavidDoolittle
          I, too, have had problems with Dreamweaver CS 3 which are not the same as yours but similar. I have had trouble switching between views - Split view to Code view and sometimes to Design view - on my G5 iMac. Often, in split view, when I click on the code pane at the top of the window, the entire window turns white! If I click back on the lower pane, sometimes the white goes away, but half the time it still remains white. This is too darn buggy for me, so, after my 30 day free trial, I am electing to not upgrade fromo Dreamweaver 2004 MX and wait for Adobe to fix this usability issue. Too bad, I was getting ready to buy the whole new Creative Suite 3, but no way will I spend that chunk of change now, just to buy such bugs. Shame on Adobe for releasing such an important product this way. I filed a bug report with Adobe, but of course, never heard a word from them; did you?
          • 2. Re: DW acting strange - does not go to code view
            corradoconti Level 1
            I did not even place a ticket with adobe yet. I only have been working on the new computer since a couple of days ago.
            My previous computer still has DW cs3 on it (waiting to be put to pasture soon) and I may try to do some surgery first: i.e. take the preferences from the old computer and swap them with the new one.
            Interestingly this is the first time anything like this happened to me and I have been using Dreamweaver since version 1 (not that V1 was anything to write home about. At the time Golive was a superior product).
            What I know is that this installation is almost unusable for me.

            However, I would suggest to you to upgrade nevertheless. Obviously it is sort of the draw of the luck. On my old computer it has been working flawlessly (but everything else didn't, that's why a bought a new one) and the difference in features between MX and CS3 is incredible.

            DW CS3, at least for my money (I develop Open Source applications) is superior to anything out there. I just would like it to work properly.
            For you PC users, you may also want to check out Notepad++ for an free alternative. Fantastic application that combined with Firefox, firebug and the FF developer toolbar can do anything and then some of what DW does.

            The only reason I am still with DW is that: 1) I am used to it and My workflow with Open Source dynamic applications is very fast 2) I actually like to use the design view to be able to quickly look at a page (despite that many of my layouts, being pure CSS , render poorly on DW) click on an element and be able to go quickly to the HTML code or the corresponding CSS rule and its parents either in the CSS panel or go from the CSS panel to the code.

            Since this is exactly where I am having issues right now, since my last post I discovered even more issues of the same nature, I am sorry to say that without a resolution I will have to modify my workflow to bypass DW and work with Firebug instead.

            The other annoying thing is that probably a reinstall may fix the issue, but with the Adobe studio edition I am not able to see a way to only unistall and reinstall DW. Do I have to unistall the entire suite? I would hate that but the installer does not give me a choice.

            I had a similar issue with Acrobat pro and the old CS2. I had to resort to download a bootleg copy of Acrobat to do a fresh installation on top of the (legal) cs2 studio Acrobat Pro to avoid a lengthy back and forth with Adobe support.
            Do I have to do the same thing with DW? Kind of silly after spending good money for the CS2 > CS3 upgrade. But if it works I don't care. I really wish CS Studio would give me an option of installing and reinstalling just one application, but when I insert the disk and launch the installer I don't see that option. Am I missing something?


            • 3. Re: DW acting strange - does not go to code view
              corradoconti Level 1
              I also wanted to give an update on the exact behavior I am experiencing:

              1) I click on an element on the layout view and nothing happens - I r-click and it works as intended (but the contextual menu also pops up)
              2) I select code in the code view and instead of highlighting the corresponding element in design view, nothing happens.
              3) When I r-click in design view on an element both the code and the CSS rule hightlights but when I select an element in code view the CSS pane does not respond at all. Other times it does show a rule but it always the last rule in my css, not the one I am selecting in code view.
              4) I click on a CSS rule in the CSS pane and I cannot go to the corresponding line of code in the CSS file about 70% of the time. When it does work half the time it takes me to the wrong place in the css file.
              5) In the code toolbar if I select a line of code all the "Comment" and other icons on the left may or may not be greyed out. Switching from one file to another (any file) and then come back to the original file sometimes makes those same icons active once again.
              6) On some files I cannot activate the "Visual Aids" toolbar icon. It stays grayed out for that page until I switrch to another page and come back.

              My guess is there are scores of other features not working properly. I just haven't got to them yet.

              What is the best way to transfer preferences, snippets, etc. from one computer to another? I want to try to capture my old preferences (code coloring, file extensions, etc.) and see if that makes a difference. At least, if I have to reinstall DW it would allow me to quickly set the new copy up with the preferences that worked just fine on my other computer.
              • 4. Re: DW acting strange - does not go to code view
                Level 7
                The times I have seen others post things like this, it's been due to a bad
                installation - reinstalling fixes it.

                > What is the best way to transfer preferences, snippets, etc. from one
                > computer
                > to another?

                PREFERENCES? No way that I know of.

                SNIPPETS? Copy the Configuration/Snippets folder from the USER-specific
                application folder and paste to a similar location on the new computer.

                XP-
                C:\Documents and Settings\<user>\Application Data\Adobe\Dreamweaver
                9\Configuration\Snippets
                (these folders are normally hidden - you may have to use Explorer > Tools >
                Folder Options to unhide them)

                VISTA-
                E:\Users\<user>\AppData\Roaming\Adobe\Dreamweaver 9\Configuration\Snippets

                or on Mac -
                Library/Application Support/Macromedia/Dreamweaver 9/Configuration/Snippets

                SITE DEFINITIONS? Export from DW on one computer to portable media, and
                Import to the other.

                --
                Murray --- ICQ 71997575
                Adobe Community Expert
                (If you *MUST* email me, don't LAUGH when you do so!)
                ==================
                http://www.dreamweavermx-templates.com - Template Triage!
                http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                ==================


                "corradoconti" <webforumsuser@macromedia.com> wrote in message
                news:f8ij7e$cli$1@forums.macromedia.com...
                >I also wanted to give an update on the exact behavior I am experiencing:
                >
                > 1) I click on an element on the layout view and nothing happens - I
                > r-click
                > and it works as intended (but the contextual menu also pops up)
                > 2) I select code in the code view and instead of highlighting the
                > corresponding element in design view, nothing happens.
                > 3) When I r-click in design view on an element both the code and the CSS
                > rule
                > hightlights but when I select an element in code view the CSS pane does
                > not
                > respond at all. Other times it does show a rule but it always the last
                > rule in
                > my css, not the one I am selecting in code view.
                > 4) I click on a CSS rule in the CSS pane and I cannot go to the
                > corresponding
                > line of code in the CSS file about 70% of the time. When it does work half
                > the
                > time it takes me to the wrong place in the css file.
                > 5) In the code toolbar if I select a line of code all the "Comment" and
                > other
                > icons on the left may or may not be greyed out. Switching from one file to
                > another (any file) and then come back to the original file sometimes makes
                > those same icons active once again.
                > 6) On some files I cannot activate the "Visual Aids" toolbar icon. It
                > stays
                > grayed out for that page until I switrch to another page and come back.
                >
                > My guess is there are scores of other features not working properly. I
                > just
                > haven't got to them yet.
                >
                > What is the best way to transfer preferences, snippets, etc. from one
                > computer
                > to another? I want to try to capture my old preferences (code coloring,
                > file
                > extensions, etc.) and see if that makes a difference. At least, if I have
                > to
                > reinstall DW it would allow me to quickly set the new copy up with the
                > preferences that worked just fine on my other computer.
                >


                • 5. Re: DW acting strange - does not go to code view
                  corradoconti Level 1
                  Thank you for your answer. Indeed a new installation was something I was contemplating. The only problem is that, according to other posts I read here and there, unistalling the CS3 studio takes a very long time (one poster claimed it took him almost 20 hours - maybe he was exaggerating but still...).
                  Plus I have already set up all my preferences and several plug ins in Illustrator and Photoshop. If I reinstall I am going to lose all of that.

                  As far as I can tell, the Adobe Installer for CS3 does not let you pick and choose the installation you want. It's all or nothing. Am I right? Or is there a trick to unistall and reinstall only one application?

                  Incidentally, I do have a copy of Dreamweaver CS3 I purchased on my own (an upgrade from DW8 before this company hired me and gave me their sitewide license) but I am leery to install it over the present Studio installation. For one thing it may just keep the corrupted preferences for another I have no idea how it would play with the existing Studio installation of the other programs.

                  If anyone has experienced this before, I am all ears. Thank you
                  • 6. Re: DW acting strange - does not go to code view
                    Level 7
                    > If I reinstall I am going to lose all of that.

                    It's unfortunate but it may be your only option.

                    > 20 hours

                    Seems a bit long to me. I have uninstalled CS3 at least 20 times, and none
                    took longer than 2 hours, with most completing far faster than that.

                    > If anyone has experienced this before, I am all ears. Thank you

                    Why not contact Adobe directly and use one of your one-on-one support
                    incidents?

                    http://www.adobe.com/support/programs/dreamweaver/index.html?tab:contact=1


                    --
                    Murray --- ICQ 71997575
                    Adobe Community Expert
                    (If you *MUST* email me, don't LAUGH when you do so!)
                    ==================
                    http://www.dreamweavermx-templates.com - Template Triage!
                    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                    http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                    ==================


                    "corradoconti" <webforumsuser@macromedia.com> wrote in message
                    news:f8jbp5$9eh$1@forums.macromedia.com...
                    > Thank you for your answer. Indeed a new installation was something I was
                    > contemplating. The only problem is that, according to other posts I read
                    > here
                    > and there, unistalling the CS3 studio takes a very long time (one poster
                    > claimed it took him almost 20 hours - maybe he was exaggerating but
                    > still...).
                    > Plus I have already set up all my preferences and several plug ins in
                    > Illustrator and Photoshop. If I reinstall I am going to lose all of that.
                    >
                    > As far as I can tell, the Adobe Installer for CS3 does not let you pick
                    > and
                    > choose the installation you want. It's all or nothing. Am I right? Or is
                    > there
                    > a trick to unistall and reinstall only one application?
                    >
                    > Incidentally, I do have a copy of Dreamweaver CS3 I purchased on my own
                    > (an
                    > upgrade from DW8 before this company hired me and gave me their sitewide
                    > license) but I am leery to install it over the present Studio
                    > installation. For
                    > one thing it may just keep the corrupted preferences for another I have no
                    > idea
                    > how it would play with the existing Studio installation of the other
                    > programs.
                    >
                    > If anyone has experienced this before, I am all ears. Thank you
                    >


                    • 7. Re: DW acting strange - does not go to code view
                      corradoconti Level 1
                      Well, I bit the bullet and I went ahead and reinstalled DW. First I uninstalled, which was pretty straightforARD. I didn't have to unistall the whole suite. just DW.
                      Then I decided not to risk it and I installed my own copy over the studio.
                      That too went well. I lost my preferences (which was a drag as I use a lot of custom key combo and settings) but I retained all the sites (that was nice).
                      The strange behavior disappeared and It also plays well with the rest of the suite.

                      I could not be happier as my workflow is very specific (I develop in Joomla, Drupal and OScommerce and since they are dynamic apps, I had to come up with a fast and reliable workflow with tight integration between DW, Firefox, Firebug and the Dev. Toolbar) and now that I am back to normal I really appreciate the time savings.

                      Thank you all for the great help.
                      • 8. Re: DW acting strange - does not go to code view
                        Level 7
                        Good luck!

                        --
                        Murray --- ICQ 71997575
                        Adobe Community Expert
                        (If you *MUST* email me, don't LAUGH when you do so!)
                        ==================
                        http://www.dreamweavermx-templates.com - Template Triage!
                        http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                        http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                        http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                        ==================


                        "corradoconti" <webforumsuser@macromedia.com> wrote in message
                        news:f8l0hc$a92$1@forums.macromedia.com...
                        > Well, I bit the bullet and I went ahead and reinstalled DW. First I
                        > uninstalled, which was pretty straightforARD. I didn't have to unistall
                        > the
                        > whole suite. just DW.
                        > Then I decided not to risk it and I installed my own copy over the studio.
                        > That too went well. I lost my preferences (which was a drag as I use a lot
                        > of
                        > custom key combo and settings) but I retained all the sites (that was
                        > nice).
                        > The strange behavior disappeared and It also plays well with the rest of
                        > the
                        > suite.
                        >
                        > I could not be happier as my workflow is very specific (I develop in
                        > Joomla,
                        > Drupal and OScommerce and since they are dynamic apps, I had to come up
                        > with a
                        > fast and reliable workflow with tight integration between DW, Firefox,
                        > Firebug
                        > and the Dev. Toolbar) and now that I am back to normal I really appreciate
                        > the
                        > time savings.
                        >
                        > Thank you all for the great help.
                        >