4 Replies Latest reply on Aug 17, 2010 1:06 PM by areohbee

    Access violation error on publish service

    Allen Gambrell

      I am writeing a publish service and am getting the following error sometimes when in the process of making the images and uploading to the server.

       

      (2144.212c): Access violation - code c0000005 (first chance)

       

      All of lightroom locks up and I have to close the program with the task manager.

       

      this happens while running the .processRenderedPhotos function

       

      Here some sudocode of what I am doing

       

      Contact Server and setup remote collection

       

      Loop for each rendition

       

           Start Task to process 4 different file sizes for server

       

           Wait for task to finnish

       

           Upload images to server

       

           Add image to database on server

       

      Next Image

       

      Clean up

       

      I am also getting the following error every time I use the "Success, ErrorMessage = Rendition:waitForRender()" function

      (20b4.23bc): C++ EH exception - code e06d7363 (first chance)

      The file makes ok, but I don't know if it is a problem?

        • 1. Re: Access violation error on publish service
          areohbee Level 5

          I haven't had such problems. But here are some ruminations which may or may not have any relevance:

           

          - I usually start a task that waits for the renditions (as opposed to waiting for the rendition then starting a task).

          - What's the purpose of starting a task if you're just going to wait for it to finish afterward?

           

          Rob

          • 2. Re: Access violation error on publish service
            Allen Gambrell Level 1

            More info

             

            Here is when it happens, I started a big upload (300 images) and then minimised Lightroom.

            Lightroom kept going fine until I went back into it, then it instantly gave me the error and locked up. This only happened when I went back into Lightroom, and when I did the user interface was all messed up with blank spaces and white and black boxes where the image would be. As I say it does not seem like anything in the plugin triggering it, but the act of Lightroom redrawing the display. This is with 3.0

             

            Here is the full error from windbg

             

            (20b4.1698): Access violation - code c0000005 (first chance)
            First chance exceptions are reported before any exception handling.
            This exception may be expected and handled.
            *** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Program Files\Adobe\Adobe Photoshop Lightroom 3\ui.dll -
            ui!AgGraphics::MeasureStyledText+0x16a:
            000007fe`ea1999ea 488b10          mov     rdx,qword ptr [rax] ds:00000000`00000000=????????????????
            • 3. Re: Access violation error on publish service
              Allen Gambrell Level 1

              Rob,

                I start 4 tasks that each render 1 image size then I wait for them all to finnish before I upload the images. I tried to include the upload in the tasks, but it generated to many ftp connections because I could not use the same connection in 4 different task (it would kick a error if it tried to upload 2 images at a time)

              • 4. Re: Access violation error on publish service
                areohbee Level 5

                I dunno Allen - something is off.

                 

                I've had multiple simultaneous ftp connections active before but I don't think they were ever to the same server.

                 

                Definitely ftp on a different task than the export/rendering task sounds good.

                 

                Sorry I haven't been more helpful.

                 

                Rob