2 Replies Latest reply on Aug 17, 2010 9:11 PM by bobba1

    problems connecting to my mySQL backend through PHP/zend on a FB4 app that works fine localhost

    bobba1 Level 1

      Hello, I am trying to take a (very) simple FB4(+ZendFramework+mySQL+PHP) app from my local environment (where it works fine on my windows 7 pro wampserver system) to my production environment (a shared server on CrystalTech running mySQL), where I am having all sorts of trouble getting it to work. The last time  I tried this, it was from the FB4 Beta and it worked fine. But this time no such luck. At first, I was getting channel disconnected errors, but after making some changes to the amf_config.ini file, I am now getting a different error message (see below). From what I can see from the error message below, it is telling me it can't find my servicecall (RespondentService1) -- but the .php file is istting in the services folder in the app directory where it should be. Does anyone have any ideas on what might be happening? btw, I originally used the zend autogenerated gateway.php file and it resulted in a "channel disconnected" and/or bad service call/url, so I had to copy and paste the gateway.php from my other FB4 app that is currently working from my production server, and now I get the error message below. I assume the error message below is "better" than an error message about a disconnected channel or a bad call/url (??). I'd appreciate any thoughts. Thanks!  Bob Class "Respondent2Service1" does not exist: Plugin by name 'Respondent2Service1' was not found in the registry; used paths: : php3/services/ #0 D:\Inetpub\avenabrand\ZendFramework\library\Zend\Amf\Server.php(550): Zend_Amf_Server->_dispatch('getAllResponden...', Array, 'Respondent2Serv...') #1 D:\Inetpub\avenabrand\ZendFramework\library\Zend\Amf\Server.php(626): Zend_Amf_Server->_handle(Object(Zend_Amf_Request_Http)) #2 D:\Inetpub\avenabrand\php3\gateway.php(47): Zend_Amf_Server->handle() #3 {main}