4 Replies Latest reply on Aug 20, 2010 6:52 AM by rascaler

    patch problem with adobe 9.3 download

    rascaler

      I am trying to download adobe 9.3 and keep getting the warning that I have to verify a patch with Adobe.  I've tried their online suggestions- a different browser and saving it to desktop to download.  Neither worked.  I'm looking for suggestions on how to fix this problem  Thanks