5 Replies Latest reply on Aug 20, 2010 3:13 PM by ImagineEditing

    CS4 Rendering wrong aspect ratio

    ImagineEditing

      I am using a Mac Pro with Snow Leopard and AE CS4. I am trying to render out a Lossless animation with HDTV 1080 29.97 (1920x1080) comp settings. The graphic has text at the bottom that is within the Title safe guidelines and everything looks normal when adding it to the Render Queue, BUT when I actually go to render it out, AE scales the whole graphic UP and the text is now being cut off at the bottom. I have pictures to show you exactly what I mean.

       

      Before Rendering:

      Before Render.jpg

      ...and During Render:

      During Render.jpg

      Why would it all of a sudden scale everything up? I rendered out 4 other graphics in the same queue, with the SAME Comp/Render settings, and only this graphic has this issue. I have tried saving it to different places, duplicating the comp, trying a different computer and everytime it scales it up during the render. Has anyone seen this before and know what the problem/solution is? Thank you.

        • 1. Re: CS4 Rendering wrong aspect ratio
          Mylenium Most Valuable Participant

          You have an effect or setting that behaves differntly during life previews and rendering. Could be something with OpenGL, 3D rendering, layer styles and effects, could be an effect that is not safe to use with MP rendering and thus disables itself. Definitely not a general problem, but rather quite specificly tied to one of these things. If you can provide more details, we may be able to advise further.

           

          Mylenium

          • 2. Re: CS4 Rendering wrong aspect ratio
            ImagineEditing Level 1

            What other details about the project/comp would you like to know? I did have Multiprocessing turned on, so since you mentioned that I tried rendering again without it on...no fix.

             

            As far as effects I'm using: I have CC Sphere & Glow (for each of the planets); Shatter (for just one of the planets); Text with ramp, drop shadows, and bevel; there are two ".Mov"s in the comp (one of them with a color key effect). That's about it.

             

            For further settings that I am using, see pictures:

             

            Media/Disk Cache Settings:

            Media settings.jpg

            Memory/Multiprocessing Settings (keep in mind I've changed this up different ways trying to make it work, this was what I used for the last attempt):

            Memory Settings.jpg

            Previews Settings:

            Previews Settings.jpg

             

            Also it might be important to note that I do have another composition that is exactly the same (which renders out perfectly), only difference is one of the planets doesn't explode. So maybe there is some setting with the effects on the comp with the exploding (using Shatter effect) planet. Thoughts?

            • 3. Re: CS4 Rendering wrong aspect ratio
              ImagineEditing Level 1

              OK! I figured out the fix...I just made all the layers not 3D and now it renders without scaling anything up. Interesting though...Still not sure why it renders differently than it looked in the Preview.

              • 4. Re: CS4 Rendering wrong aspect ratio
                Todd_Kopriva Level 8

                I can't tell with the tiny text in the screenshot, but I think that you are looking at the composition through the Front view. Keep in mind that the final render will be done through the Active Camera view.

                 

                See this page about choosing a camera view and this page about camera and the active camera.

                • 5. Re: CS4 Rendering wrong aspect ratio
                  ImagineEditing Level 1

                  YOU SOLVED IT! I had "fixed" it by taking all the layers out of 3D. But really my issue was that I was viewing the "front" and not the active camera. I didn't realize it made a difference unless I actually had a camera in the comp. But I went back to the original comp that was scaling during the render and changed the camera view to active and sure enough it was all scaled up. Good to know now that the "active camera" is what will render out. Thank you, Todd!