23 Replies Latest reply on Aug 30, 2011 7:53 AM by odyssey27

    I get type lag in Flash Builder 4

    GoodNewsJim Level 1

      I had type lag in Flex too.

       

      It is often like 100-1000 ms lag after I type a letter.  If  I type a bunch of letters at once, they lag then all appear at once.

       

      I'm a VERY FAST typer and programmer, I need speed to keep myself focused.

       

      What could be causing this lag?  Could it be the autocomplete(which I don't use anyway) or something?

       

      MS Word or Notepad have no type lag, and I have a gaming computer I bought last summer for Starcraft2, so its not my computer.

       

      What are some settings I can turn off to get no type lag?  I'm 381 hours into a project right now, going to publish in a few weeks.  This isn't stopping me from programming, but I'd be much happier and more productive if I had no type lag.

       

       


      The way I handle lag is that I do my typing expecting where the cursor will be by counting lines up and down as I move, then I try and press delete X times where X is the number of things I need to delete, but if I mess up, I have 5 keystrokes in advance doing a major typo.  And if I can't think 5 moves in advance, I just have to wait out lag for a while when I should be trucking along in an ordinary editor with no lag.

        • 1. Re: I get type lag in Flash Builder 4
          Sameer Bhatt Adobe Employee

          Do you get this lag while editing .mxml files or .as files?

          Can you tell us the steps to reproduce this issue?

          • 2. Re: I get type lag in Flash Builder 4
            GoodNewsJim Level 1

            Both .mxml and .as

             

            It seems like the editor does it always, even with new documents.

            I think the editor's smart feature to try and autocomplete things might be doing it.

             

            Does anyone know how to turn autocomplete off maybe?

            • 3. Re: I get type lag in Flash Builder 4
              GoodNewsJim Level 1

              *redundant comment  deleted*

              • 4. Re: I get type lag in Flash Builder 4
                Sameer Bhatt Adobe Employee

                So, you are just creating a new Project with the default configuration and you are getting the lag?

                Well, I'm not able to reproduce this issue locally.

                Can you give more information about the exact steps to nail down this issue. For example, the type of project, any source folder attached, any other setting which you have changed, etc..

                • 5. Re: I get type lag in Flash Builder 4
                  Anirudh Sasikumar Adobe Employee

                  Out of curiosity, how fast do you type (a rough Words Per Minute count?)

                  • 6. Re: I get type lag in Flash Builder 4
                    GoodNewsJim Level 1

                    I only type letters 35-70 WPM, but I'll show you a situation where I really type super fast: 6-10 keypresses a second

                     

                     

                    Disclaimer: "This does not reproduce the problem, but it shows a situation where fast typing engages."

                     

                    Sometimes my editing will look like something like this:

                     

                        <s:DropDownList visible="false" x="1080" y="640" id="pcombo1"  change="pcombo1selected(event);">
                            <s:ArrayCollection>
                                <fx:Object label="0 True" />
                                <fx:Object label="1 RESERVED" />
                                <fx:Object label="2 Boss Destroyed" />
                                <fx:Object label="3 Selected Monster/Generators destroyed" />
                                <fx:Object label="4 A==TRUE" />
                                <fx:Object label="5 A==FALSE" />
                                <fx:Object label="6 B==TRUE" />
                                <fx:Object label="7 B==FALSE" />
                                <fx:Object label="8 C==TRUE" />
                                <fx:Object label="9 C==FALSE" />
                                <fx:Object label="10 D==TRUE" />
                                <fx:Object label="11 D==FALSE" />
                                <fx:Object label="12 E==TRUE" />
                                <fx:Object label="13 E==FALSE" />
                                <fx:Object label="14 F==TRUE" />
                                <fx:Object label="15 F==FALSE" />
                                <fx:Object label="16 G==TRUE" />
                                <fx:Object label="17 G==FALSE" />
                                <fx:Object label="18 H==TRUE" />
                                <fx:Object label="19 H==FALSE" />
                                <fx:Object label="20 I==TRUE" />
                                <fx:Object label="21 I==FALSE" />
                                <fx:Object label="22 J==TRUE" />
                                <fx:Object label="23 J==FALSE" />
                                <fx:Object label="24 K==TRUE" />
                                <fx:Object label="25 K==FALSE" />
                                <fx:Object label="26 L==TRUE" />
                                <fx:Object label="27 L==FALSE" />
                                <fx:Object label="28 M==TRUE" />
                                <fx:Object label="29 M==FALSE" />
                                <fx:Object label="30 N==TRUE" />
                                <fx:Object label="31 N==FALSE" />
                                <fx:Object label="32 O==TRUE" />
                                <fx:Object label="33 O==FALSE" />
                                <fx:Object label="34 P==TRUE" />
                                <fx:Object label="35 P==FALSE" />
                                <fx:Object label="36 Q==TRUE" />
                                <fx:Object label="37 Q==FALSE" />
                                <fx:Object label="38 R==TRUE" />
                                <fx:Object label="39 R==FALSE" />
                                <fx:Object label="40 S==TRUE" />
                                <fx:Object label="41 S==FALSE" />
                                <fx:Object label="42 T==TRUE" />
                                <fx:Object label="43 T==FALSE" />
                                <fx:Object label="44 U==TRUE" />
                                <fx:Object label="45 U==FALSE" />
                                <fx:Object label="46 V==TRUE" />
                                <fx:Object label="47 V==FALSE" />
                                <fx:Object label="48 W==TRUE" />
                                <fx:Object label="49 W==FALSE" />
                                <fx:Object label="50 X==TRUE" />
                                <fx:Object label="51 X==FALSE" />
                                <fx:Object label="52 Y==TRUE" />
                                <fx:Object label="53 Y==FALSE" />
                                <fx:Object label="54 Z==TRUE" />
                                <fx:Object label="55 Z==FALSE" />
                            </as:ArrayCollection>
                        </s:DaropDownList>

                     

                    To Construct this, I copy Paste:

                                <fx:Object label=" ==TRUE" />

                                <fx:Object label=" ==FALSE" />

                    26 times:

                     

                                <fx:Object label=" ==TRUE" />

                                <fx:Object label=" ==FALSE" />

                                <fx:Object label=" ==TRUE" />

                                <fx:Object label=" ==FALSE" />

                                <fx:Object label=" ==TRUE" />

                                <fx:Object label=" ==FALSE" />

                                <fx:Object label=" ==TRUE" />

                                <fx:Object label=" ==FALSE" />

                                <fx:Object label=" ==TRUE" />

                                <fx:Object label=" ==FALSE" />

                    ...

                     

                    Then I assembly line go down them

                    1

                    2

                    3

                    4

                    5

                    6

                    7

                    8

                    9

                    1

                    1

                    1

                    1

                    1

                    1

                    1

                    1

                    1

                    1

                    1

                    1

                    ...

                     

                    Then I come back and get the 1s and make them:

                    10

                    11

                    12

                    13

                    14

                    15

                    16

                    17

                    ...

                     

                    Then I type in the letters:

                    A
                    A

                    B

                    B

                    C

                    C

                    D

                    D

                    E

                    E

                    ...

                     

                    As you can see, typing numbers and moving arrow keys sequentially can be incredibly fast if your skilled at it

                    Down Arrow Key

                    Left Arrow Key

                    Letter

                    *repeat*

                     

                    With any type lag at all you just hope your sequence of typing had no errors, but it typically will.   You can see how super fast typing really cares about the difference between 1ms and 1000 ms type lag since you're pressing about 10 keys a second.

                     

                    Haven't you ever experienced type lag yourself?  I get it so often that I didn't think anything in particular triggered it.

                    The next time it happens to me, I will post here my exact code that I was editing.

                     

                    I appreciate your attention to this problem.  Next time I reproduce it, I'll post here.

                    • 7. Re: I get type lag in Flash Builder 4
                      separ8

                      I think an alternative to this would be to program the required output to a trace function and copy past the lot

                      • 8. Re: I get type lag in Flash Builder 4
                        GoodNewsJim Level 1

                        I found a situation that reproduces it, but I was on a live gotomeeting with another person, so I couldn't stop what I was doing to document it.

                         

                        The situation involves this though:

                         

                        Sometimes when Flash is using its autocomplete functionality, the whole system lags for a moment.  This isn't bad if you like autocomplete, but if you don't use autocomplete, its a pain.  If you're editing several rows where its checking autocomplete, it can lag up a ton.

                         

                        Is there some option to turn off autocomplete?

                         

                        I'll get a better example once I run across it again.

                        • 9. Re: I get type lag in Flash Builder 4
                          Sameer Bhatt Adobe Employee

                          How much is the lag? Do you have any source folders attached? There was a similar issue when source folders are attached which is fixed now - http://bugs.adobe.com/jira/browse/FB-27301

                           

                          You can disable auto-activation of code-hints by Window->Preferences->Flash Builder->Editors--- Enable auto-activation

                          By unchecking this option, only the auto-activation of code-hints will be disabled. You can still invoke code-hints manually by ctrl+space.

                           

                          Also, it'll be great if you can provide us with a reproducable case so that we can look into the issue further.

                          • 10. Re: I get type lag in Flash Builder 4
                            GoodNewsJim Level 1

                            Thanks for helping me disable code hints.  I'll see if that is the case.

                             

                            I'm working on a medium sized project I wrote, my main.as is 27,600 lines of code.

                            So maybe Flex just acts sluggish on big projects.

                             

                            One place it always lags is when I use ctrl+z rapidly in succession

                             

                            But sometimes it lags when I do something, but then when I try to do the exact same thing over again, it does not lag.

                             

                            Typing is not always laggy, but sometimes it is.  My computer is not slow on anything else, so it isn't a virus or lots of programs in the background.

                            • 11. Re: I get type lag in Flash Builder 4
                              GoodNewsJim Level 1

                              I FOUND AN EXAMPLE WHERE THIS HAPPENS!  I hope the mod is still here.

                               

                              http://www.goodnewsjim.com/images/typelag1.jpg

                               

                              http://www.goodnewsjim.com/images/typelag2.jpg

                               

                              Notice how I'm changing "debugsumx" to "i"

                              and "debugsumy" to "j"

                               

                              Everytime I change one, there is type lag for about .5-1 sec, as all the previous versions of "i" or "j" is highlighted.

                               

                              That serves no purpose for me except annoying type lag.

                               

                              How do I turn this off?

                               

                              Thanks for helping me turn off autocomplete.

                              • 12. Re: I get type lag in Flash Builder 4
                                Radhakrishna Bhat

                                Hi,

                                 

                                There is a bug logged for this issue. https://bugs.adobe.com/jira/browse/FB-27463

                                Please add your comments to it about the problems you are facing.

                                 

                                -Radhakrishna

                                • 13. Re: I get type lag in Flash Builder 4
                                  w.johnson

                                  Just updated to FB 4.0.1 using the standalone updater. I was experiencing the same type lag in an mxml editor (1 second per character) and noticed the reference to the source path bug. With the source path removed, the editor is again responsive. Was that bug really fixed?


                                  • 14. Re: I get type lag in Flash Builder 4
                                    Sameer Bhatt Adobe Employee

                                    The source path issue - http://bugs.adobe.com/jira/browse/FB-27301 was fixed after 4.0.1 released.

                                    • 15. Re: I get type lag in Flash Builder 4
                                      GoodNewsJim Level 1

                                      I get so much type lag sometimes I get an error that says something about Java heap space, I click ok and then another error window pops up and Flash Builder closes.  I'm not sure why you get more type lag if you have a bigger text file, this makes no sense.  Just because I have 42,000 lines of code in one of my .as files doesn't mean I should get 1 second or more of type lag.  I don't get type lag when moving the cursor, just when entering or deleting text.         

                                      • 16. Re: I get type lag in Flash Builder 4
                                        GoodNewsJim Level 1

                                        I just noticed something.  When I restart the application and start again, I have no type lag.  So I'm thinking this might be due to some nasty memory leak that happens over time.  I have no lag to start, then I get lag over time as I edit a very large file.  I'll screen shot the java heap error next time         

                                        • 17. Re: I get type lag in Flash Builder 4
                                          Anirudh Sasikumar Adobe Employee

                                          Have you tried this on Flash Builder 4.5?

                                          • 18. Re: I get type lag in Flash Builder 4
                                            GoodNewsJim Level 1

                                            Anirudh, I'll update to 4.5 now and let you know.  It takes a few days of being on my computer to replicate, so best I can get back in next week.  I'm glad you guys care because it bothers me greatly.

                                            • 19. Re: I get type lag in Flash Builder 4
                                              GoodNewsJim Level 1

                                              Yes, I also get type lag in Flash Builder 4.5. 

                                              I really think there should be some way to turn off "All post processing except maybe ctrl+z"

                                              I don't know of any other text editors that have type lag in them.

                                              • 20. Re: I get type lag in Flash Builder 4
                                                GoodNewsJim Level 1

                                                Question if anyone wants to debug this problem:

                                                 

                                                Do you want me to run FB 4.5 into the ground and get the heap error for you?

                                                It seems like type lag gets longer and longer for every character I type, and requires a restart to get quick responses for an hour or so.

                                                I can run this baby into the ground and get the heap error if you think it'd help your debuggers.

                                                But I'd prefer to keep restarting FB 4.5 every 1-2 hours to reset the type lag.

                                                • 21. Re: I get type lag in Flash Builder 4
                                                  GoodNewsJim Level 1

                                                  I have learned that if you close the file you're working on, and reopen it, that temporarily fixes the lag too.

                                                  • 22. Re: I get type lag in Flash Builder 4
                                                    GoodNewsJim Level 1

                                                    My file is 45,983 lines long.  I'm trying to get the heap error.  I wonder if this will help.

                                                    • 23. Re: I get type lag in Flash Builder 4
                                                      odyssey27 Level 1

                                                      You're lucky you only get a lag. Wait til the editor flat locks-up for 5 minutes.