2 Replies Latest reply on Aug 31, 2010 7:12 AM by Mike6679

    RTMP Netstream NOT working with latest version of flash Player

    Mike6679 Level 1

      Let me preface this by saying: This is definitely a bug either with latest Adobe Flash Player or the streaming Media Server (in this case Real Helix):

       

      In the latest version of the Flash player (10.1.82.76) Code that worked  previously in version 10.1.53.64 does not work now. This is basic code to connect to an RTMP server (Real Helix) using Netstream class. NOW the video does not even display and there is no error message . THIS ONLY OCCURS in a BROWSER . Also I am using swfobject to display the flash and I tried with latest version and the old 1.4.1 version.

       

      Adobe please look into this, Is this possibly a problem with Real Helix OR Flash Player itself......I can't imagine nobody has come across this before?!

       

       

       

       

      private function init():void
              {
                 
                  video = new Video();
                     
                  NetConnection.defaultObjectEncoding = ObjectEncoding.AMF0;
                  nc = new NetConnection();
                  nc.client = this;
                  nc.addEventListener (NetStatusEvent.NET_STATUS,checkConnect);
                     
                  nc.connect(rtmppath);
                 
              }
              //---BEGIN: Video Handling methods ----------------------------------------------
              private function onBWDone():void
              {
              }
              //------------------------------------------------
              private function checkConnect (e:NetStatusEvent):void
              {
                  trace(flag_Running);
                 
                  if(flag_Running)
                    return;
                 
                  var msg:Boolean=false;
                  msg = (e.info.code=="NetConnection.Connect.Success");
                 
                  flag_Running=true;
                 
                      if (msg)
                      {
                          ns = new NetStream(nc);
                         
                          ns.client = {onMetaData:ns_onMetaData, onCuePoint:ns_onCuePoint,onPlayStatus:ns_onPlayStatus,netStatus:onNetStatus};
                          ns.addEventListener(AsyncErrorEvent.ASYNC_ERROR, asyncErrorHandler);
                          ns.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
                          ns.addEventListener(NetStatusEvent.NET_STATUS,onNetstreamStatus); //only handles errors right now

                          //vidDisplay is a Video object in the library (Video - actionscript controlled)
                          vidDisplay.attachNetStream(ns);
                          // set the smoothing value from the constant
                          vidDisplay.smoothing = SMOOTHING;
                         
                          setVolume(DEFAULT_VOLUME);
             
                          bolLoaded = true;
                         
                          trace("NetConnection.Connect.Success");
                         
                          cur_state = STATE_CONNECTED;
                          callback(MESSAGE_TYPE_VID_INIT_DONE,null);
                      }
                      else
                      {
                          trace("Load Video Failed: NetStatusEvent " + e.info.code);
                          callback(MESSAGE_TYPE_ERROR,null,"Load Video Failed: NetStatusEvent " + e.info.code);
                      }
                                             
                 
                     
              }

        • 1. Re: RTMP Netstream NOT working with latest version of flash Player
          Filip Nowak

          I've the same problems with streaming of audio from FlourineFx streaming server. The both NetStream.seek() and the NetStream's play method with starttime parameter provided doesn't work. It worked without problems with previous Flash Player version 10.1.53.64.

          Any idea?

           

          EDIT: We also noticed the same problems with Red5 streaming server.

           

          Many thanks

          Fipil

          • 2. Re: RTMP Netstream NOT working with latest version of flash Player
            Mike6679 Level 1

            This is confirmed as a REAL HELIX Bug. Here is what I recevied from them:

             

             

            This has already been fixed (not yet released). For existing servers to work with the
            latest Flash player (10.1.82.76)  you need to add the following to the top level of
            your server config file

             

            <List Name="RTMP">
               <List Name="Scheme2">
                   <List Name="Versions">
                       <Var v1="0x80000702"/>
                   </List>
               </List>
            </List>

             

             

            I put this in the config file and restarted the server, and it worked!

             

            -Mike