1 Reply Latest reply on Sep 1, 2010 9:00 AM by Zen Seven

    Weird debugger behaviour after upgrading to latest version of Flash

    Zen Seven Level 1

      Hello everyone,

       

      After some critical updates that Adobe was touting last month, I updated my flash player and it hasn't worked properly since. When I hit debug in Flex 3 the IDE opens up my browser and I get tons of garbage spewing out into my output window, like so:

       

      4119 AVMINF: MTHD ReferenceError () @ 0x039384B3

      4121 AVMINF: MTHD Error () @ 0x039382B4

      4123 AVMINF: MTHD Object () @ 0x03938665

      4124 AVMINF: MTHD Class/get prototype () @ 0x103B29E0

      4126 AVMINF: MTHD Class/get prototype () @ 0x103B29E0

      4128 AVMINF: MTHD global$init ()

      4129 AVMINF: MTHD game.common::cPoint$cinit ()

      4131 AVMINF: MTHD global/flash.net::registerClassAlias () @ 0x103B29E0

      4132 AVMINF: MTHD global/flash.net::getClassByAlias () @ 0x103B29E0

      4134 AVMINF: MTHD ReferenceError () @ 0x039384B3

      4135 AVMINF: MTHD Error () @ 0x039382B4

      4137 AVMINF: MTHD Object () @ 0x03938665

       

      It goes on and on and on... sometimes even outputting what looks like assembly. I've tried reverting versions but all I get is unresponsiveness in the browser.

       

      When I run without the debugger, it crashes the browser. This is with both the latest Chrome and the latest Firefox.

       

      I'm stuck.

       

      Has anyone seen this problem before?