2 Replies Latest reply on Sep 9, 2010 12:10 AM by vsh07

    PDF opens in Reader but Reader is not my default viewer

    DWC121 Level 1

      I have doPDF as one of my printers so I can create a PDF file. In Control Panel Folder Options, my default PDF viewer is set to Foxit. That is what I want. I have Acrobate Reader on my PC for the rare instances I NEED Acrobate Reader. When I select doPDF to create a PDF file, the generated PDF file is opened but it opens in Acrobate Reader instead of Foxit (doPDF opens the newly created file apparently for verification that the PDF was created). Since Foxit is my default viewer, why does the PDF open in Acrobate Reader instead of Foxit? (Neither the Foxit people nor the doPDF people know why).

       

      BTW... When I select a PDF file in Windows Explorer, it opens in Foxit.

       

      In advance, Thanks

        • 1. Re: PDF opens in Reader but Reader is not my default viewer
          pwillener Level 8

          Since the reader is opened by 'doPDF', that program is responsible how it is opened.  I have no idea how 'doPDF' does that...

          • 2. Re: PDF opens in Reader but Reader is not my default viewer
            vsh07 Level 2

            In Run type regedit and open following registry path(Second part may differ from machine to machine):

            HKEY_USERS\S-1-5-21-762979615-2031575299-929701000-XXXXXX\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\.pdf

             

            registry.JPG

             

            On the Right panel ,right click and Add "String Value" by the name "Application" and then Modify(Right Click) this "Application" and add Value data as the name of application by which you want open pdf file.Eg. If you want to make Acrobat as your default application ,put Acrobat.exe or put  AcroRd32.exe if you want Reader as your default app. Similarly put the name of corresponding .exe for other pdf Readers you have and you want to make a particular as your default app.For knowing the name of  exe of other Readers, just check in “OpenWithList” just below .pdf(on left).

            I hope it can solve your problem