5 Replies Latest reply on Sep 19, 2011 11:23 PM by rajibdugar

    Browse sequence in Windows Vista 64-bit?

    eeddings

      This is a duplicate post.  I posted it nestled down in another browse sequence thread and didn't get any nibbles, so I am creating a new thread.  I hope no one minds.

       

       

       

      Hi all, I'm wondering if I can get a little help from the gurus here.  I've been through the forums and internet trying to find the answer to browse sequences and glossary tabs in Windows Vista 64-bit.  I am running Windows Vista 64-bit Home Premium Service Pack 2.

       

      I need to mention that my .chm files work fine on Windows XP (multiple machines tested).  My project consists of a master .chm (thanks Peter Grainge for the step-by-step, which I followed to the letter) with 15 slave projects.

       

      I've copied the hhactivex.dll from the Program Files\Adobe\RoboHelp\RoboHTML (426 KB) on my Windows XP machine and saved it in the following folders on my Windows Vista 64-bit machine:

      • c:\windows\system32
      • c:\windows\sysWOW64

       

      I then tried using the cmd.exe command prompt (as administrator) in c:\windows\system32 to do the following:

      1. regsvr32 c:\windows\system32\hhactivex.dll
      2. regsvr32 c:\windows\system32\hhctrl.ocx

       

      Both commands registered successfully.  When I opened the .chm, the glossary and browse sequence are still not working properly.

       

      So, I then tried unregistered hhactivex.dll and hhctrl.ocx in the c:\windows\system32 folder using the regsvc32 and the cmd.exe (as administrator) in that same folder.

       

      I then tried using the cmd.exe command prompt (as administrator) in c:\windows\sysWOW64 to do the following:

      1. regsvr32 c:\windows\sysWOW64\hhactivex.dll
      2. regsvr32 c:\windows\sysWOW64\hhctrl.ocx

       

      Both commands registered successfully.  When I opened the .chm, the glossary and browse sequence are still not working properly.

       

      I've been pulling my hair out on this one.  I've seen posts mentioning the "Unblock" Button on the .chm's Properties - General tab - Advanced dialog, but I do not have an Unblock button anywhere in the properties for these .chms.  I also do not have the Microsoft KB 89xxxxx security updates on my Vista 64-bit computer that I can find.

       

      I also say a post that put the path/filename in quotes when using regsvr32.  I tried registering again using the same scenarios above in system32 (regsvr32 "c:\windows\system32\hhactivex.dll") and sysWOW64 (regsvr32 "c:\windows\sysWOW64\hhactivex.dll") but still I cannot get the browse sequences/glossary to work in thses compiled .chms -- whether opening the master or the slave.

       

      After I registered the hhactivex.dll on a Windows XP test machine, if I opened a .chm and then went into Windows Explorer and tried to delete the hhactivex.dll, I'd get a "file in use" error.  However, when I open a .chm on my Vista 64-bit machine and try to delete the hhactivex.dll in either system32 or sysWoW64, it deletes without error.  I verified this with all of the different registering methods I described in this post (registering, testing, unregistering, moving to next folder, etc.).  Being able to delete the .dll on the Vista machine tends to make me believe that the .dll isn't really registering,  Either way, it isn't being accessed when a .chm file is opened like on a Windows XP machine.

       

      I've been around the internet trying to find out exactly how to register .dlls in Vista 64-bit, and unless I'm totally missing something I believe I am doing this correctly.  If I am doing something wrong, could someone guide me in the right direction with a complete step-by-step method that works in Vista 64-bit?

       

      I have yet to test Vista 32-bit or any version of Windows 7, but I am hoping that once I resolve the problem in Vista 64-bit that the rest will be non-issues.  I hope anyway, as I have no means to test those platforms.

       

      Thanks in advance for making it to the end of this long post of mine.  I appreciate any help!

       

      eeddings

       

       

        • 1. Re: Browse sequence in Windows Vista 64-bit?
          Amebr Level 4

          Just kind of thinking out loud here. You don't say where your chm files are located. I assume in Program Files somewhere? If so, perhaps try the chms in C:\temp or something similar to see if Unblock is available then. If it works, I think it might point to special security restrictions in "Program Files" - I don't have any solutions, but it might help with researching the problem.

          • 2. Re: Browse sequence in Windows Vista 64-bit?
            eeddings Level 1

            Thanks for the response, Amebr.  Good thinking -- I thought of that too.  Actually, I tried them in several locations -- c:\, c:\temp, c:\users\owner\documents, c:\users\owner\desktop\temp, etc.  I tried registering the .dll in each location with the files as well.  No matter where the files are stored, I have no Unblock button on the Properties\General\Advanced dialog.

             

            I'm 99% sure this is an issue where the hhactivex.dll not registered properly or in the right location, as the hhactivex.dll is usually always the culprit when browse sequence/glossary don't work on one machine but do on another.

             

            But, I really don't know where else to look or what else to do, so I turned to these forums.  I appreciate any thoughts and comments -- anything and everything might help.  Most likely I'm just doing something wrong.

            • 3. Re: Browse sequence in Windows Vista 64-bit?
              Captiv8r Adobe Community Professional & MVP

              Hi there

               

              We are all stumped and your likely course of action would be to contact Adobe support.

               

              Personally, my own gut feeling is that an issue exists with the DLL in a 64 bit environment. But I never claim to know it all and could easily be wrong.

               

              Also, I've noticed recent versions of RoboHelp (7 and 8) seem to have a rather generic issue with the DLL not working properly. I was using XP Pro 32 bit prior to upgrading to Windows 7 64 and was having issues with seeing the special Browse Sequence area in CHMs I would create. Once in a blue moon it would work, but largely it wouldn't. I reported to Adobe only to be met with what I interpreted as them shrugging their shoulders as if they were stumped too and it sucked to be me.

               

              Cheers... Rick

               

               

              Helpful and Handy Links

              Begin learning Captivate 5 moments from now! $29.95

              Captivate Wish Form/Bug Reporting Form

              Adobe Certified Captivate Training

              SorcererStone Blog

              Captivate eBooks

              • 4. Re: Browse sequence in Windows Vista 64-bit?
                eeddings Level 1

                Thanks for the response, Captiv8r.  I do have a support ticket in with Adobe, but am awaiting a response.  I will be sure to let everyone know what they say.

                 

                Yeah, I'm stumped along with everyone else on this one.  Any thoughts or comments may help us all find a solution, so if someone has an idea or thought, please don't hesitate.  I could be overlooking something so simple that I'll have a "duh" moment.

                • 5. Re: Browse sequence in Windows Vista 64-bit?
                  rajibdugar

                  The 32bit version of HH.exe is kept in "C:\Windows\SysWOW64". When you double click a CHM file on a 64 bit machine, it launches the 64 bit version of hh.exe kept in C:\Windows or C:\Windows\System32 directory.

                   

                   

                  To launch a CHM with 32 bit version hh.exe, run the following command in a 64 bit machine C:\Windows\SysWOW64\hh.exe <CHM file Path>

                   

                   

                  The other good news is that you can get the 64 bit version of HHActiveX.dll in RoboHelp 9.0. It is kept at "<RoboHelp 9.0 install folder>\Redist\x64\HHActiveX.dll"

                   

                  If RoboHelp 9.0 is installed on your machine, this activeX control is already registered. Otherwise you need to register this DLL.

                   

                  To register 64bit version of HHActiveX.dll,

                  1> Run Command prompt(cmd.exe) as administrator

                  2> Type "regsvr32 <64 bit HHActiveX.dll full path>" and press Enter.

                  3> This should show that the registration is done successfully.

                   

                   

                  Now working with 64 bit version of HH.exe should also show Glossary and Browse Sequences.