7 Replies Latest reply on Sep 3, 2010 12:41 AM by Valdur55

    Webservice dont respond

    Valdur55

      Hi, i have a problem with my Flash Application.

       

       

      If I host my flash app on the same server as tomcat with the webservices and the database my application works fine.

      Even from other pcs in totally different networks it works.

      But if i try to split the flash application from the web service server (which i suppose is one of the main advantages of web services WSDL) the flash application stops the receive data from the web services.

       

       

      I thought maybe there a problem with the port 8080 i used for my web services, so i switched it to the port 80 so nothing in the web should block the standard http port.

       

      I have really no idea what could be the problem.

       

      Maybe the hosts for the Flash application are doing some **** with the requests (www.kilu.de or http://www.funpic.de/, both hosts which are offer space for free)

       

      I hope someone can give me some help here. I am rlly new in publishing flash application maybe there is an deeper fault on my site why it wont work...

       

       

      Regards Valdur

        • 1. Re: Webservice dont respond
          Flex harUI Adobe Employee

          Hook up a network monitor like Charles and see where the requests are going.

          1 person found this helpful
          • 2. Re: Webservice dont respond
            rakeshpant

            You will have to add crossdomain.xml to root directory of your web service server, so that flex application can connect to it. If you are using same server for flex and webservice and you don't need that.

            Hope is helps.

            1 person found this helpful
            • 3. Re: Webservice dont respond
              Valdur55 Level 1

              On which position exacly would you install the network monitor, the only place where i have access to install stuff is the webservice server itself.

              • 4. Re: Webservice dont respond
                Valdur55 Level 1

                I will try the thing with the crossdomain.xml when i come back from work, where can i get the crossdomain.xml i think i have seen a file named like that before but im not sure where...

                • 5. Re: Webservice dont respond
                  rakeshpant Level 1

                  A typical crossdomain.xml file has following contents:

                  <?xml version="1.0"?>
                  <!DOCTYPE cross-domain-policy SYSTEM "http://www.adobe.com/xml/dtds/cross-domain-policy.dtd">
                  <cross-domain-policy>
                      <site-control permitted-cross-domain-policies="all"/>
                      <allow-access-from domain="*"/>
                  </cross-domain-policy>
                  

                   

                  
                      
                      
                  
                  
                  • 6. Re: Webservice dont respond
                    Valdur55 Level 1

                    Ok i have created the policy file and placed it in the right folder i suppose (http:/xyz.com/crossdomain.xml). It looks like that:

                     

                    <?xml version="1.0"?>
                    <!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
                    <cross-domain-policy>
                    <site-control permitted-cross-domain-policies="all"/>
                    <allow-access-from domain="*" to-ports="1-65000" />
                    </cross-domain-policy>

                     

                     

                    This is maybe not the best config but it should be the allow everything for test purpose right?

                     

                     

                    I tried Charles and i can confirm that the flash file requests the crossdomain.xml and receives it.

                     

                     

                    After that i installed a network sniffer on my server and saw that the flash file requests after the crossdomain.xml

                    the WSDL file of my web service server and the XSD file. Both of the file are successfully send to the flash application.

                     

                     

                    And then nothing, the part where the flash application should now starts to call the web service is missing, it seems to me that the flash application did not send a request because the network sniffer on my server stops after the the three previous described requests.

                     

                     

                    Anyone an idea?

                     

                    Regards Valdur

                    • 7. Re: Webservice dont respond
                      Valdur55 Level 1

                      Still not solved... :/