2 Replies Latest reply on Sep 2, 2010 2:59 PM by Dave LaRonde

    After Effects out of memory and 3D layers

    stillrendering

      I have a

      Dual Core 3.6 Ghz

      3.25 GB ram

      hp workstation xw8200

       

      My question is that I am working in CS4 After Effects and using Zaxwerks 3d ProAnimator and Sapphire Effects.  In this present project my computer keeps crashing and cant even render a single 3d layer with 2 effects on it.   It has been taxing to make any rendering progress what so ever.  Lots of "Out of Memory" errors and some "Open GL errors" both which are leading to file corruption and renaming and then crashing.

       

      It is a new computer with plenty of space on the two drives. I have my project caching pointing to C drive where programs are and it has 170 GB of space and my source and AE projects are on E which is a TB.

       

      What is the solution?  Is it my render settings?  I tried the secret setting of cache dumping.  Didnt help.

       

      When it comes to 3D layers is it just that my computer is not big and bad enough?

       

      What would you suggest for proper Ram and Core to use After Effects in this way?

       

      Thanks,

      Stillrendering

        • 1. Re: After Effects out of memory and 3D layers
          Szalam Adobe Community Professional & MVP

          What are your memory and multiprocessing settings? You have a tiny amount of RAM for AE work. That's the first thing that jumps out to me.

          The second thing is OpenGL errors. Turn off OpenGL. I don't know of anybody that uses it to render and I don't even use it in my preview window.

          • 2. Re: After Effects out of memory and 3D layers
            Dave LaRonde Level 6

            3.25 GB ram....

            ...I am working in CS4 After Effects and using Zaxwerks 3d ProAnimator and Sapphire Effects... Lots of "Out of Memory" errors and some "Open GL errors" both which are leading to file corruption and renaming and then crashing.

            Okay, turn off multiprocessing RIGHT NOW and leave it off until you get more memory.  You're woefully short on it.  I'll assume you're running a 64-bit OS, which means you can get a bunch.  AE can use up to 4 GB PER CORE in multiprocessing mode, including hyperthreaded cores.  Do the arithmetic.

             

            An Open GL error should be an immediate clue: turn off Open GL.  It frequently does more harm than good, as you're painfully aware.

             

             

            It is a new computer with plenty of space on the two drives.

            In your case, that's irrelevant.  You need RAM, and how!  AE is the ultimate RAM hog.