15 Replies Latest reply on Jan 19, 2009 9:56 PM by Alan Musselman

    Can't add images to slideshow

    Tab4WebDesign
      I just installed Web Premium. I created a slideshow and have just opened the xml file to add images. When I click the "create" button I get the following message: "slideshow XML file has be"
      That's it. It does nothing else. It hangs up right here. It looks as though there should be more to the message because according to the instructions after you add more images to an existing slideshow and click on "create", you will be prompted to update the file, then the slideshow will be created with the new images.

      Does anyone else have this problem and will I have to uninstall the whole suite and re-install?
        • 1. Re: Can't add images to slideshow
          Level 7
          Yes, this happened to me as well, the crucial word that is missing is
          'updated' I think.

          http://fasterthanu.com/

          I put together three galleries on that example all at different times, so it
          does work. If you continue to have problems, I'll go through it, but from
          memory it does update it pretty instantaneously which surprised me and I was
          also searching for a problem that wasn't there :-)

          Peter
          ______________________
          "Tab4WebDesign" <webforumsuser@macromedia.com> wrote in message
          news:f86b4k$emm$1@forums.macromedia.com...
          |I just installed Web Premium. I created a slideshow and have just opened
          the
          | xml file to add images. When I click the "create" button I get the
          following
          | message: "slideshow XML file has be"
          | That's it. It does nothing else. It hangs up right here. It looks as
          though
          | there should be more to the message because according to the instructions
          after
          | you add more images to an existing slideshow and click on "create", you
          will be
          | prompted to update the file, then the slideshow will be created with the
          new
          | images.
          |
          | Does anyone else have this problem and will I have to uninstall the whole
          | suite and re-install?
          |


          • 2. Re: Can't add images to slideshow
            Level 1
            Hmm that is strange. Looks like the error message is getting truncated so we'll check it out on our end. The Slideshow command is functioning properly though so no need to un-install and like Peter mentioned it happens really fast.

            The message should read "slideshow XML file has been updated"

            • 3. Re: Can't add images to slideshow
              Level 7
              Alan,

              I thought the Slideshow was a has been ;)

              alex

              Alan Musselman wrote:
              > Hmm that is strange. Looks like the error message is getting truncated so we'll
              > check it out on our end. The Slideshow command is functioning properly though
              > so no need to un-install and like Peter mentioned it happens really fast.
              >
              > The message should read "slideshow XML file has been updated"
              >
              >
              >
              • 4. Re: Can't add images to slideshow
                Tab4WebDesign Level 1
                Yeah, I checked inside my images and thumbnail folders and those new images weren't there, so the slideshow didn't get updated. I could add the images manually to each folder, but that would defeat the purpose of having the program do it for me.

                I was really looking forward to using this feature within fireworks and hope someone may have a solution.
                • 5. Re: Can't add images to slideshow
                  Level 1
                  Silly Alex! Good to see you around these days. Hope all is well!

                  Tab4WebDesign -

                  I just tried one more time and cannot reproduce the problem you are seeing where the images are not getting pushed into the folder.

                  Here's what Im trying and let me know if Im missing a step somewhere:

                  1. Open the Create Slideshow command
                  2. Add an Album with Images
                  3. Add another Album with Images
                  4. Add properties for each album
                  5. Export out Slideshow (used player_white) to a specified folder
                  6. Re-open the slideshow in the command by clicking "Open existing AlbumBook" in the command
                  7. Add additional images to each Album
                  8. Click Create

                  Actual Results:
                  Additional images were added to the existing slideshows

                  Expected Results:
                  Its working as expected...

                  Something interesting to note is I did close the Create Slideshow command before adding additional images. Not sure if that makes a difference or not, but thought Id mention it.
                  • 6. Re: Can't add images to slideshow
                    Tab4WebDesign Level 1
                    Wow, thanks for the quick reply!!

                    Yeah, all the steps that I did, you had above. Several days had passed since I re-opened the xml file to add the new images. Instead of just going under "file" to open I went under "Command" once again and clicked on "create slideshow" then clicked on "Open An Existing Album Book". Then I opened the album and under images I clicked on the plus sign to add new images.
                    • 7. Re: Can't add images to slideshow
                      Tab4WebDesign Level 1
                      Does the xml file save automatically as a "read only" file? Because I just tried to open under "file" and the file type was set on "All readable files" and that xml file was not showing.
                      • 8. Re: Can't add images to slideshow
                        Tab4WebDesign Level 1
                        I tried to open the index file and got an error message that reads: "The HTML document contains one or more images with absolute web addresses for the source. Fireworks cannot handle these images."

                        I surrounded the slide show with my html code and the slideshow works fine here: http://www.2ndchancefund.org/photoalbums/index.html

                        (My page probably ... or more than likely does not validate to standard code.)

                        Could this be why the photo album can't get updated....because I have wrapped my web page around the photo album?
                        • 9. Re: Can't add images to slideshow
                          Level 1
                          Ah I wonder if thats the problem. When opening an existing albumbook (slideshow), you simply need to select the folder that contains the slideshow.xml file, add more images to the albums and click "Create"

                          I just noticed you mentioned you tried to open the XML file in Fireworks. You do not need to open the file in Fireworks as Fireworks doesnt understand that file format or know what to do with it.

                          I hope I understand your issue. Thanks!

                          ps - Slideshow looks great on your site!

                          • 10. Re: Can't add images to slideshow
                            johara7
                            I am getting the same message "Slideshow XML file ("slideshow.xml") has be", an I know what the rest of it says thanks to this thread. But I when I open an existing album and I add more images and this message appears, I then chack the xml file and it has indeed been updated but with missing information in the new image lines. It ceates the width and height as "undefined", and when I check my slideshow the new images have not been added. Does anyone know what is up with that?

                            Thanks!
                            • 11. Re: Can't add images to slideshow
                              distantskunk
                              Me too. How do I fix this issue?
                              • 12. Can't add images to slideshow
                                distantskunk Level 1
                                I noticed that there was not an answer to this problem yet.

                                I just went to update a slide show to add an image...and BAM...there it is again!

                                "slideshow xml file ("slideshow.xml") has be"

                                Has anyone been able to figure out this bug????

                                What I do to get around the issue, is start from scratch with the a brand new slide show. HOWEVER, when the slide show is being created, the display window says "Launch Slideshow in bro"

                                What the...!
                                • 13. Re: Can't add images to slideshow
                                  Dusty99
                                  Did anyone ever figure this out why the images and thumbnails don't export, etc? I have the problem too. It does npt ask if I want to over write the existing slideshow like the write up on the Adobe web site says it should.

                                  It looks like this has been a documented problem since at least July 2007!
                                  • 14. Re: Can't add images to slideshow
                                    distantskunk Level 1
                                    When Fireworks CS3 creates a slideshow, it generates two folders.

                                    One is called “scripts” that you do not need to mess with and then the other, which is where the generated photos are stored, is named by you when the slideshow is originally created. This file, which I usually call “Gallery”, has two sub-folders, called “thumbs” and “notes”.

                                    To add a new photo to a current slideshow:

                                    Edit the image size (I use Fireworks) of the photo, with the exact dimensions of the other photos, located in the “Gallery” folder. Place a copy of the edited image into the "Gallery" folder.

                                    Also, create the thumbnail of the same photo, with the exact dimensions of the other thumbnails, located in the “thumbs” folder, and then place a copy in the “thumbs” folder.

                                    Now the images are located where Fireworks is going to look for them when you edit the program.

                                    Open Fireworks > Commands>Creative Slideshow.

                                    Click on “Open Existing Album”

                                    Search for the XML file located in the root for the slide show.

                                    Click the title of the slideshow in the Albums box to display the images in the images in the Images box.

                                    Now, Click the + button and add the new photo you placed in the “Gallery” folder by clicking the “…” button. Search for the image and click Done.

                                    Click create…If you see the stupid half-message that says, “Processing… Slideshow XML file (“slideshow.xml”) has be…" Don’t worry, click Close to get the message to go away, and then click the X on the window to close the slideshow program.

                                    That’s it…you should now have your slideshow updated.

                                    To remove a photo from the slide show:

                                    Delete the photo from the “Gallery” folder and then the “thumb” folder.
                                    Open Fireworks > Commands>Creative Slideshow.
                                    Click on “Open Existing Album”
                                    Search for the XML file located in the root for the slide show.
                                    Click the title of the slideshow in the Albums box to display the images in the images in the Images box.
                                    Click the photo you want to be removed from the program, then click the – button.
                                    Click Create…that’s it.

                                    Good luck!
                                    • 15. Re: Can't add images to slideshow
                                      Level 1
                                      Wow good response skunk!

                                      We fixed the bug/truncation in Fireworks CS4 and improved the user experience as well!