7 Replies Latest reply on Oct 20, 2010 3:38 PM by C. Agruss (Adobe)

    FB4 plugin does not work with Eclipse Cocoa versions (3.5 & 3.6)

    mig56 Level 1

      I am trying to install Flash Builder 4 plugin in Eclipse Cocoa 3.6 or 3.5 (32 bit) and they both install but I am not able to launch the Flash perspective. If I install Eclipse 3.5 Carbon version the Flash perspective works. Both 3.5 and 3.6 have the same error messages in the Eclipse log file. So from what I can see, the Flash plugin is not support in the Cocoa versions. Is this correct? Will the 64bit version be supported in the near future?

       

      My machine setting:

      Mac OS 10.6.4

      Java 1.6.0_20

       

      Eclipse Log file:

      BootLoader constants: OS=macosx, ARCH=x86, WS=cocoa, NL=en_US

       

      !ENTRY org.eclipse.core.jobs 4 2 2010-09-07 10:44:23.748

      !MESSAGE An internal error occurred during: "Creating Adobe Flash Player trust file...".

      !STACK 0

      java.lang.NoClassDefFoundError: com/adobe/flexbuilder/utils/osnative/NativeControl

      at com.adobe.flexbuilder.project.internal.PlayerTrustStore.getUserFlashPlayerTrustFolder(Pla yerTrustStore.java:198)

      at com.adobe.flexbuilder.project.internal.PlayerTrustStore.<init>(PlayerTrustStore.java:81)

      at com.adobe.flexbuilder.project.internal.PlayerTrustStore.getInstance(PlayerTrustStore.java :71)

      at com.adobe.flexbuilder.project.internal.FlexProjectCore$4.run(FlexProjectCore.java:388)

      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

      Caused by: java.lang.ClassNotFoundException: com.adobe.flexbuilder.utils.osnative.NativeControl

      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:494)

      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)

      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)

      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.jav a:105)

      at java.lang.ClassLoader.loadClass(ClassLoader.java:248)

      ... 5 more

       

      !ENTRY org.eclipse.ui 4 0 2010-09-07 10:44:26.028

      !MESSAGE Unhandled event loop exception

      !STACK 0

      org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NoSuchFieldError: handle)

      at org.eclipse.swt.SWT.error(SWT.java:3884)

      at org.eclipse.swt.SWT.error(SWT.java:3799)

      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:137)

      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3405)

      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3102)

      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)

      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)

      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)

      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)

      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)

      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)

      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)

      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)

      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)

      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)

      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)

      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:597)

      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)

      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)

      at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

      Caused by: java.lang.NoSuchFieldError: handle

      at com.adobe.flexbuilder.ui.UIPlugin$1.run(UIPlugin.java:120)

      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)

      ... 22 more