9 Replies Latest reply on Sep 12, 2010 6:25 AM by Vandey0321

    I can't set Adobe Reader 9.3.4 as default .pdf

    Vandey0321

      When I double click .pdf it doesn't open with Adobe Reader (AR). It used to open with AR 8 but wouldn't print from 8. I figured out that it would print from AR 9 and consequently deleted the AR 8 folder. However, now it won't associate .pdf with AR 9. I understand the simple trick of right-clicking, "open with..." and browsing or selecting Adobe Reader. I have found the Adobe Reader .exe file and when I click it, it doesn't select it in the default programs nor in the "other programs".

       

      I am able to open AR 9 and manually look for the file and open it.

       

      I'm running Windows 7 32-bit with Adobe Reader 9.3.4. Can't positively be sure I've effectively deleted all of AR 8. Thanks for the help.

       

      --J

       

      PS please cut down on the jargon. I'm semi-computer savvy but to be safe...

        • 1. Re: I can't set Adobe Reader 9.3.4 as default .pdf
          Vandey0321 Level 1

          I forgot to also mention that in "cmd" prompt, when I type "assoc .pdf" it

          lists ".pdf=AcroExch.Document"

           

          Also in regedit, HKEY_CLASSES_ROOT  /AcroExch.Document / Shell/Open/Command I've got "C:\Program files\Adobe\Reader 9.0\Reader\AcroRd32.exe" "%1"

           

          Don't know if that helps.

          • 2. Re: I can't set Adobe Reader 9.3.4 as default .pdf
            vsh07 Level 2

            I once posted a reply to address a similar problem:

            http://forums.adobe.com/message/3096168#3096168

            1 person found this helpful
            • 3. Re: I can't set Adobe Reader 9.3.4 as default .pdf
              Vandey0321 Level 1

              Thanks for the link. It definitely gave me another path to try. However, after creating "AcroRd32.exe" in HKEY_USERS/S-1-5....etc......pdf, still nothing happens. PDFs still aren't opened by Reader and I still can't browse for the reader. I checked the .pdf "openwithlist" and AcroRd32.exe is in there as an example.

              I don't know how to upload a picture so I can't show you the screen shot of the file as proof so you'll have to take my word on it.

               

              Jeremy

              • 4. Re: I can't set Adobe Reader 9.3.4 as default .pdf
                vsh07 Level 2

                Not a problem at all,I believe you completely .

                On Reading your post once again I found you wrote

                "It used to open with AR 8 but wouldn't print from 8. I figured out that it would print from AR 9 and consequently deleted the AR 8 folder".

                Have you unistalled Reader 8 and then installed Reader 9 or simply deleted the folder?

                I think association to AcroRd32.exe has got disturbed(AcroRd32.exe does not indicate its of AR8 or AR9).

                So we will do another thing to solve your problem.

                1.Unistall Reader from Control Panel>Add or Remove programs

                2.Download 9.3.4 reader from http://ardownload.adobe.com/pub/adobe/reader/win/9.x/9.3.4/enu/AdbeRdr934_en_US.exe and run it.

                Please tell if this (reinstallation) solves your problem?

                (Note:If you face problem in unistallation ,download the Windows Installer Cleanup  Utility from http://majorgeeks.com/Windows_Installer_CleanUp_Utility_d4459.html and run it.)

                1 person found this helpful
                • 5. Re: I can't set Adobe Reader 9.3.4 as default .pdf
                  Vandey0321 Level 1

                  So I opened Control Panel, clicked on "Programs" to uninstall a program. I found Adobe Reader 9 in the list so I uninstalled it. No problems occurred and it seemed off my computer. I reinstalled it (I had done this the other day as well) and to my dismay, no progress. PDFs still won't associate and I can't use "open with" and browse for it still. Sorry to confound you even further.

                  • 6. Re: I can't set Adobe Reader 9.3.4 as default .pdf
                    Ankit_Jain Adobe Employee

                    Can you please try the following:

                     

                    1. Open My Computer. Then choose Tools -> Folder Options -> File Types.

                     

                    2. Now  look for PDF-extension in the Registered File Types-list. If it's  there, click Advanced (if not, just create it with "New"). An Edit File  Type-dialog should appear.

                     

                    3. If the "Open"-option is already on the  list, click "Edit", if not, create it by clicking "New". Now click  Browse and search for the program you wish to open the file with (Reader 9 in your case). (Make sure that the path is enclosed in quotes ("..."))

                     

                    Just click Ok, and you're done. You can also set an icon for the file by clicking "Change Icon" if you wish..

                     

                    This worked for me, hope it works for you as well.

                    • 7. Re: I can't set Adobe Reader 9.3.4 as default .pdf
                      Vandey0321 Level 1

                      Hi, Thanks for helping! Do you think you could make this pertinent to Windows 7? I can't find a "Tools" in "Computer". I found a folder options but it doesn't have "File Types" in it.

                       

                      However, I tried a circituitous route: I went into Control Panel --> Programs then clicked "Make a file type always open in a specific program" . Scrolled down to .pdf and found it was not associated with anything (Unknown Application). However, though I could find Reader 9 when I browsed, I could not get it to stick (as described in earlier posts). It just would not show up in the box after clicking on it.

                       

                      Sorry to add you to the list of defeated answers. Hope you can help.

                      • 8. Re: I can't set Adobe Reader 9.3.4 as default .pdf
                        Ankit_Jain Adobe Employee

                        Aplogies for providing a XP centric solution instead of a Win7 centric one. As I said earlier, the program that you're pointing to isn't registered correctly.

                        You can achieve the same results as I described earlier through the following registry changes.

                         

                        1. In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name. (something like AcroRd32.exe)

                         

                        2. Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable (Again ensure that there are double quotes around the location of the executable), hit Okay and then try and reassociate the file type as you normally would.

                        In all probability, your location to the executable contains a space in between, and double quotes are requred to correctly associate the path for the EXE.

                         

                        Hopefully, this should work...

                        • 9. Re: I can't set Adobe Reader 9.3.4 as default .pdf
                          Vandey0321 Level 1

                          You did it. You are a mother-flippin' genius!

                           

                          I had navigated into HKEY_CLASSES_ROOT...etc. before but not to application but to the file type. Under AcrRd32.exe, the location was listed as

                          "C:\Program Files\Adobe\Reader 8.0\Reader\AcroRd32.exe" "%1"

                          Of course I had Adobe 9 and simply switching the folder name to 9 fixed the issue. Thanks so much for your help and diligence.

                           

                          Jeremy