2 Replies Latest reply on Sep 13, 2010 2:03 AM by DV_DONE

    Problems with the SMIL-plugin

    DV_DONE

      I've played around a little bit with the SMIL-plugin and ran in to some problems that might be possible bugs. Hope somebody could shed some light on this.

       

      1. Adding the attribute clipBegin and/or clipEnd seems to be ignored in the creation of all elements in a dynamic streaming switch. This might even be ignored on a single video element, I haven't tried that out though. I have also tried to add the "s" (seconds) suffix in the time value, but according to the TimeUtil.parseTime comments a suffix such as "s" or "min" is not needed in the time value since seconds is the default value.

       

      Example code:
      <smil>
          <head>
              <meta base="rtmp://domain/application" />
          </head>
          <body>
          <switch>
              <video src="mp4:ncode/video_7018_430" system-bitrate="430000" clipBegin="50" />
              <video src="mp4:ncode/video_7018_800" system-bitrate="800000" clipBegin="50" />
              <video src="mp4:ncode/video_7018_1200" system-bitrate="1200000" clipBegin="50" />
              <video src="mp4:ncode/video_7018_1800" system-bitrate="1800000" clipBegin="50" />
              <video src="mp4:ncode/video_7018_2400" system-bitrate="2400000" clipBegin="50" />
            </switch>
          </body>
      </smil>

       

      2. Just adding a video element without a swith throws an error:
      ERROR : error ID=1009 detail=Error #1009: Cannot access a property or method of a null object reference.

       


      Thanks in advance!

       

      Daniel