1 Reply Latest reply on Sep 9, 2010 5:14 PM by C. Agruss (Adobe)

    Error install trial version of Flash Builder 4 in WIN runs on VMWare

    Wang4181

      After the installation, I go the errors... please help! Thanks.

      In the Setup dialog, I chose c:\Program Files\Adobe as the install location.

      Why did it try to access vmware-host\Shared Folders?

       

      ERROR: 14921 Unable to create directory "\\vmware-host\Shared Folders\Documents\..\Adobe Flash Builder 4

      ERROR: 14921 Command ARKCreateDirectoryCommand failed.

       

       

      ERROR: 14921 Unable to delete directory "\\vmware-host\Shared Folders\Documents\..\Adobe Flash Builder 4". Error 2 The system cannot find the file specified.

       

       

      ERROR: 14921 Error rolling back command ARKCreateDirectoryCommand

       

       

      ERROR: 14919 Unable to delete file copy at "C:\Program Files\Adobe\Adobe Flash Builder 4\configuration\config.ini" Error 3 The system cannot find the path specified.

       

       

      ERROR: 14919 Error rolling back command ARKMoveFileCommand

       

       

      ERROR: 14918 Unable to delete directory "C:\Program Files\Adobe\Adobe Flash Builder 4\configuration". Error 2 The system cannot find the file specified.

       

       

      ERROR: 14918 Error rolling back command ARKCreateDirectoryCommand

       

       

      ERROR: 14856 Unable to delete file copy at "C:\Program Files\Adobe\Adobe Flash Builder 4\AMT\application.xml" Error 3 The system cannot find the path specified.

       

       

      ERROR: 14856 Error rolling back command ARKMoveFileCommand

       

       

      ERROR: 14855 Unable to delete file copy at "C:\Program Files\Adobe\Adobe Flash Builder 4\AMT\application.sif" Error 3 The system cannot find the path specified.

       

       

      ERROR: 14855 Error rolling back command ARKMoveFileCommand

       

       

      ERROR: 14854 Unable to delete directory "C:\Program Files\Adobe\Adobe Flash Builder 4\AMT". Error 2 The system cannot find the file specified.

       

       

      ERROR: 14854 Error rolling back command ARKCreateDirectoryCommand

       

       

      ERROR: 23 Deleting Registry Key - failure. Error 5

       

       

      ERROR: 4 Unable to delete file copy at "C:\Program Files\Adobe\Adobe Flash Builder 4\FlashBuilder.exe" Error 3 The system cannot find the path specified.

       

       

      ERROR: 4 Error rolling back command ARKMoveFileCommand

       

       

      ERROR: 3 Unable to delete file copy at "C:\Program Files\Adobe\Adobe Flash Builder 4\artifacts.xml" Error 3 The system cannot find the path specified.

       

       

      ERROR: 3 Error rolling back command ARKMoveFileCommand

       

       

      ERROR: 2 Unable to delete file copy at "C:\Program Files\Adobe\Adobe Flash Builder 4\.eclipseproduct" Error 3 The system cannot find the path specified.

       

       

      ERROR: 2 Error rolling back command ARKMoveFileCommand

       

       

      ERROR: 1 Unable to delete directory "C:\Program Files\Adobe\Adobe Flash Builder 4". Error 2 The system cannot find the file specified.

       

       

      ERROR: 1 Error rolling back command ARKCreateDirectoryCommand

       

       

      ERROR: The following payload errors were found during install:

       

       

      ERROR:  - Adobe Flash Builder: Install failed

       

        • 1. Re: Error install trial version of Flash Builder 4 in WIN runs on VMWare
          C. Agruss (Adobe) Level 3

          Hi,

           

          Looks as if you have your home folder on VMWare mapped back to the host OS drive, and that's triggering the initial failure in the log you posted. There's a faulty assumption in our installer's home folder logic that you've encountered, where it thinks your home folder is one level above your Documents folder, though we know that's not always true.

           

          Here's a workaround you could try:

          - Back up your Documents folder for safe keeping (\\vmware-host\Shared Folders\Documents)

          - create a new folder tree named \\vmware-host\Shared Folders\home\Documents. The folder in the middle doesn't need to be named "home", you can call it anything you want, but there needs to be a new folder in the middle. Make sure you have write access to that home folder, as well as to its Documents subfolder.

          - in VMWare Windows, reconfigure your User settings, moving your "My Documents" location down to the one created below \home\.

           

          That last step varies a little, depending on which version of Windows you're running. On Win7 you can do it this way:

          - in your user home folder (\Users\yourUserName) locate the My Documents icon, and right-click it

          - choose Properties

          - in the "Location" tab, click Move, and then choose the \\vmware-host\Shared Folders\home\Documents fodler you created earlier on your VMWare host

           

          On Vista, you can right-click the Documents icon in your Start Menu, choose Properties, and from there on it's about the same as on Win7.

           

          On WinXP it looks slightly different:

          - right-click your My Documents icon (often on the desktop for convenience), and select Properties

          - the tab you want is named "Target" on WinXP, and then you can click Move to relocate it to the same location described earlier.

           

          After moving your Documents location this way, I would reboot first, and then make sure any old copies of FB4 are completely removed before re-installing. I just tested this out on my own VMWare machine (Vista), and it worked here, so with any luck it will work there too.

           

          Let me know how it goes,

           

          -Chris

           

          P.S. We'll be fixing this problem in the next release, but can only offer this workaround for now. Thanks for bearing with us.