1 Reply Latest reply on Sep 11, 2010 2:32 AM by Heetiesz

    Flash builder - Debug - Thread suspended - no errors

    Heetiesz

      Hi,

       

      I have this weird, and very annoying error, actually it's not an error but it is (confusing i know )

       

      I build a debug version of my Flex app and i get a "Thread suspended" with no errors at all. Fb(Flash builder) highlights a line of code in the UIComponent.as class file :  'public function set document(value:Object):void'.

       

      So ho did this happen:

      - Everything was working fine

      - Updated the Flex SDK to the 4.5 (Hero) beta, so i could use the new S:Image instead of mx:Image.

      - Did a build not a compile with no errors.

      - Went ahead and expanded a list itemrenderer to hold a checkbox and an image

      - Compiled and got this error.

       

       

      What I tried:

      - Rollback to SDK 4.0 didn't solve the issue.

      - Removing all changes after SDK install didn't resolve the issue

       

      I tried pinpointing where the error occured: I'ts definatly before my main file gets executed, i know nothing more.

       

       

      Anyone have any clue/idea or possible a sollution to what this issue means?