2 Replies Latest reply on Aug 7, 2007 1:37 AM by Newsgroup_User

    Background In Templates

    ImADreamgenius
      Hello everyone,

      I am not a dreamweaver genius as my name implies, I just couldn't think of a better one. Anyways, I am attempting to make a template for my website in dreamweaver. I have a background image for my template and on every page I want that same background image but when I try to create and .html document off the template the background image doesn't appear. Then when I try to add it in by going to page properties it says I cannot edit the properties.

      Is there any way I can either #1 simply get the image to appear or two edit the properties after the temaplte is made?

      Thanks!
        • 1. Re: Background In Templates
          Level 7
          On Mon, 6 Aug 2007 23:09:19 +0000 (UTC), "ImADreamgenius"
          <webforumsuser@macromedia.com> wrote:

          > Is there any way I can either #1 simply get the image to appear

          It should be doing that automatically, if you used the template
          properly. Can you upload it somewhere and post a link to it?
          • 2. Re: Background In Templates
            Level 7
            On Mon, 6 Aug 2007 23:09:19 +0000 (UTC), "ImADreamgenius"
            <webforumsuser@macromedia.com> wrote:

            >Hello everyone,
            >
            > I am not a dreamweaver genius as my name implies, I just couldn't think of a
            >better one. Anyways, I am attempting to make a template for my website in
            >dreamweaver. I have a background image for my template and on every page I want
            >that same background image but when I try to create and .html document off the
            >template the background image doesn't appear. Then when I try to add it in by
            >going to page properties it says I cannot edit the properties.
            >
            > Is there any way I can either #1 simply get the image to appear or two edit
            >the properties after the temaplte is made?
            >
            > Thanks!


            Sounds like you may have fallen into the same trap as many others and
            not created the template correctly.

            Did you create the new html page - put in the background image and
            save the template with the menu command:

            File | Save as Template

            ???

            if you can copy and paste the first dozen lines of the template file
            here we can advise


            it should look something like:
            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
            " http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
            <html xmlns=" http://www.w3.org/1999/xhtml">
            <head>
            <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
            <!-- TemplateBeginEditable name="doctitle" -->
            <title>Untitled Document</title>
            <!-- TemplateEndEditable -->
            <style type="text/css">
            <!--
            body {
            background-image: url(/img/engineersdream.jpg);
            background-repeat: repeat;
            }
            -->
            </style>
            <!-- TemplateBeginEditable name="head" --><!-- TemplateEndEditable -->
            </head>

            <body>
            <!-- TemplateBeginEditable name="EditRegion3" -->EditRegion3<!--
            TemplateEndEditable -->
            </body>
            </html>
            --

            ~Malcolm N....
            ~