8 Replies Latest reply on Sep 13, 2010 2:46 PM by Todd_Kopriva

    Problem with Avi-import (lots of information added)

    Westrabua

      Hello Adobe-forum-community,

       

      short story about me:
      Im kinda new to the whole video-editing-world. I started out some months ago with Vegas Movie studio and fell in love with creating my own videos somehow (especially game-montages atm). Recently I realized that my lowbudget-movie-studio lacks some features I would like to add to my montages (masking, 3D-techniques, ...). I looked around on the web and realized that I could get the whole Adobe package for an amount of money that I could afford (student-pack).
      So I decided to try out the Premiere-Pro-CS5-trial, before I actually buy the production-premium-student-pack with Premiere CS5, AfterEffects CS5, etc.

       

      Now my problem:
      I cant get my avi-files to work in Premiere.
      Before the flaming starts, I have to say that I already informed myself about this issue in this forum and things like "avi is just a container, doesnt tell anything,..." (thanks to Bill´s article) arent new to me by now.

       

       

      I will now try to give you as much information about the "avi"-file as I can, to make it easier for you to help me:
      As I said earlier, I do game-montages atm. So I usually start out with recording some gameplay with a programm called "PlayClaw" (fraps-alternative; works much better imo). I record at fullscreen with 60 fps and something called "light-compression" (its neccesary, cause otherwise I would get 7,5 GB data each minute; it also gives the best preformance while gaming).
      After that I usually look through my clips with Virtualdub, just to get rid off useless footage. All I do with Virtualdub is selecting the "good" parts of the gameplay and save it once again as avi with the option "direct stream copy" for audio and video, so that the format and the quality stays the same. After that I can delete the big files to get back some space on my harddisk.

       

      I also used Gspot, to get some more informations about the clip(s) I want to import into PremierePro:

      Gspot.png

       


      Another thing that might be interesting for you, is the fact that I did a complete fresh install of Windows7-64bit on my PC just some hours ago. The only thing I installed along with PremierePro by now are:
      - sounddriver
      - graphics-card-driver (ATI HD 5850)
      - firefox
      - vlc player
      - PlayClaw (the recording programm)
      - Virtualdub (well, it doesnt need to get installed)

       

      So no additional driver packs and stuff at the moment.
      I also made a screenshot of my sequence-settings in PremierePro (I really dont know if I am right with those; probably not :P):

       

      adobe.png

       

      I hope this is enough information for now and maybe someone can help me.

        • 1. Re: Problem with Avi-import (lots of information added)
          shooternz Level 6

          G SPot is showing a CODEC called TAMB

           

          That maybe the issue!

           

          BTW: well posted with really good info. Someone will nail this for you from that  I am sure.

          • 2. Re: Problem with Avi-import (lots of information added)
            John T Smith Adobe Community Professional & MVP

            A Google shows a lot of hits for codec tamb

            http://www.google.com/#hl=en&expIds=25657,25901,26515&sugexp=ldymls&xhr=t&q=codec+tamb&cp= 10&pf=p&sclient=psy&aq=f&aqi=&aql=&oq=codec+tamb&gs_rfai=&pbx=1&fp=652e0df67dbfff88

             

            But... since I have never seen that codec mentioned in the PPro forums before... a couple of questions

             

            1 - have you verified with the vendor that this codec is certified to work with Premiere Pro?

             

            2 - have you further verified with the vendor that this codec is certified to work with CS5 Premiere Pro 64bit?

            • 3. Re: Problem with Avi-import (lots of information added)
              Westrabua Level 1

              Yeah you are right, the TAMB thing is a problem. Just did a little research:

              PlayClaw-developers are working on a 64-bit-version of the TAMB-codec at the moment (so its clear that the raw files cant work).

               

               

              I just realized that my sequenze settings need to fit my material. So I just resized a clip to 1280x720 and used something called uncompressed (it still used a certain codec) in Virtualdub, and I turned off the audio for that test:

               

              clip.png

               

              And yes, now I can import the clip and play it back!

              But I really dont know if thats the best choice.

              On another test, where I left the audio on and didnt compress it, I were still able to play the file back, but it stuttered really much.

               

              So its clear that I need to resize/compress the raw files out of PlayClaw in VirtualDub, before I import them into PremierePro.

               

              To be honest, I dont think its the best now to install every codec that I can find and start testing around with every single one, til I maybe find a good solution.

              I found this list with supported formats in PremierePro.

              So what do you guys think would be a good choice (audio- and videocodec-wise), to save as much quality from the raw footage for editing, using a codec on that list?

               

              Thanks in advance!

              • 4. Re: Problem with Avi-import (lots of information added)
                Colin Brougham Level 6

                Ditto on what John said, regarding the codec. This is a bizarre, esoteric, and (based on the information i found) old/extinct codec. Since Premiere Pro CS5 is a 64-bit application, it needs 64-bit codecs, and I think it is highly unlikely you will find a 64-bit version of this TAMB codec.

                 

                If you can play these videos back in something like Windows Media Player, you should be able to use another application to convert the files to something Premiere Pro CS5 can edit. To minimize quality loss, you'll want to look at something like Lagarith or the Ut Video Codec; both are available in 64-bit version. You'll have to experiment with video converter apps; there are dozens/hundreds of them, and most should give you the opportunity to test them out before purchase (though many are free and suitable).

                 

                WHATEVER you do, don't download a bunch of crazy codec packs that promise the ability to playback any type of video, in any kind of program. They're just bad news.

                 

                EDIT: Whoops--you were posting as I was You're on the right track: if they bring out a 64-bit version of the codec, you'll be fine, but in the meantime you'll have to convert. It sounds like you're familiar with VDub, and since it imports and allows you to convert files in this codec, you can use any codec you find intrinsic to Premiere (you've used uncompressed, which basically means that each frame is as big as it can be, but is playable just about anywhere), or any codec that has a 64-bit variant and is flexible in frame size and frame rate. The two I mentioned above (Lagarith and Ut) are popular and reliable choices.

                1 person found this helpful
                • 5. Re: Problem with Avi-import (lots of information added)
                  Westrabua Level 1

                  Ok, I tried out both codecs now, that you suggested Colin.

                  I forgot to mention that I use the 32-bit-version of VirtualDub, cause the 64-bit-one couldnt handle the TAMB-files in the past (I feel so dumb right now!!!).

                  Anyway, installed 32- and 64-bit versions of both codecs, to test everything.

                   

                  My test-clip:

                  - 24 seconds

                  - 0.85 GB

                  - 1680x1048 (yeah, should be 1050 actually, strange thing)

                   

                  Lagarith-codec:

                  - 24 seconds

                  - 1.65 GB

                  - 1280x720

                   

                  UT-codec-RGB (ULRG) :

                  - 24 seconds

                  - 1.82 GB

                  - 1280x720

                   

                  UT-codec-YUV420 (ULY0) :

                  - 24 seconds

                  - 0.98 GB

                  - 1280x720

                   

                   

                   

                  So the filesize pretty much got doubled on the first two ones, actually not what I wanted to achieve. Especially because the lagarith-clip seems to play back really poorly in PremierePro (far from being smooth, actually not able to work with that). Strange thing is that the UT-clip plays back pretty well, both of the.

                  Right now, I dont get what the difference between those two UT-codecs is (those are different settings in the same codec btw). I mean the RGB-one outputs double the data as the YUV420-one. Even if I toogle the program-window (dunno if thats the right name) and set the playback-quality to full, I cant see a quality difference in those two (also plays back the same way).

                  If someone knows the difference, I am really interested to hear it.

                   

                   

                  Next step will be to find the right audio-codec for this particular case. Dont know if I should just install lame-codec and go with mp3, or are there maybe some better choices?

                   

                  Btw, thats what GSpot gives at this point:

                   

                  UL-RGB.png

                   

                  ULY0.png

                   

                  EDIT: Will be back later. Thanks so far!

                  • 6. Re: Problem with Avi-import (lots of information added)
                    Westrabua Level 1

                    Alright, I am done with testing and solved my problem.

                    Now I will post here again, just to show a way that helped me to get the PlayClaw-Raw-Clips into PremierePro:

                     


                    You need a 32-bit-version of VirtualDub (cause there´s no 64-bit-TAMB-codec out now) and need to install a 32-and-64-bit-version of the Ut-Video-Codec (works really good; 32-bit for VirtualDub and 64-bit for PremierePro).

                    Then resize the clip to 1280x720 (use the filter called "resize"), set in the video-tab to full-processing-mode and choose the Ut-Video-Codec under compression with the following settings:

                     

                    VD-settings.png

                     

                    If you also want the recorded audio, then go to the audio-tab and simply set to "Direct stream copy". Otherwise set to "No audio".

                     

                    After these steps, Gspot should give you something like that about your clip:

                     

                    Gspot-Good.png

                    Now the clip got converted to something that PremierePro can use.

                     

                    My Sequence-settings in PremierePro look like this:

                    adobe.png

                    If you havent recorded at 60 fps, then change the timebase-setting to fit your original footage.

                     


                    About FRAPS (also tested it; just wanted to know if it works the same):

                    With FRAPS its actually a bit easier, because FRAPS somes with a 64-bit-codec. That means that you can start right away with a 64-bit-VirtualDub-version and dont need to install a 32-bit-UT-video-codec-version. But thats the only difference, everything else works the same.

                     

                     

                    On a note:

                    This is neither the only way to do it, nor the right way for every material that PlayClaw/FRAPS can give you.

                    BUT this is a way that works:

                    - plays back in PremierePro like a charm

                    - Ut-video-codec saves the quality from the raw files pretty well

                    I even did a testedit and rendered it with the H.264-format and the HDTV-720p-29.97-High-Quality-preset, just to see how it looks in the end, and I have to say that it´s REALLY good quality-wise for this kind of footage in my opinion so far (after all the final game-montages I have seen the last months).

                     

                    And because there hasnt been a good work around for this PlayClaw/FRAPS-Raw-files (atleast I couldnt find one as I had the problem), I thought its worth to write it down for some other new PremierePro users.

                     

                     

                    Now I can concentrate on learning the workflow and some new techniques.^^

                     

                    Also:

                    Thanks to all in this thread. Your suggestions and hints got me on the right way to come up with a solution.

                    • 7. Re: Problem with Avi-import (lots of information added)
                      Stan Jones Adobe Community Professional & MVP

                      Congratulations!  And thanks for posting that solution.

                      • 8. Re: Problem with Avi-import (lots of information added)
                        Todd_Kopriva Level 8

                        As Stan said, thank you for posting back with what worked for you. That is very courteous and all too rare. I'll make a special effort to help you the next time you have a question. ;-)