1 Reply Latest reply on Sep 14, 2010 2:58 AM by Neobox75

    URL not found error while loading photo on Linux

    Piotr Wierzgała Level 1

      Hi,

       

      I have a AIR 2.0 appliaction which works perfectly well on Windows but while I run it on Linux Loader object can't load any photo. I tried many path variations but I always get Error #2035: URL Not Found.

       

      Here's how I load a photo (with hard coded URL)

      _imageLoader.load(new URLRequest("/home/piotr/105755/damage_photos/17.jpg"));

       

      I'm sure that "/home/piotr/105755/damage_photos/" path is correct. I pasted it to files explorer address text input and expected directory was opend. I'm also sure that 17.jpg file exists in that directory.

       

      When I trace IOError message it says: Error #2035: URL Not Found. URL: app:/home/piotr/105755/damage_photos/17.jpg

       

      My questions are:

      What "app:" does in my URL... can it cause the problem? If yes, how can I get rid of it?

      Is there anything specific about UNIX systems and Loader that should I know about?

      How can I load file from hard drive other way than by Loader object?

       

      I use AIR 2.0 SKD, Flex 4.5 SKD and Ubuntu 10.04. Could anyone help me, please?