0 Replies Latest reply on Sep 15, 2010 12:55 AM by Phuong Thanh

    why effect lable don't run when it in <repeater>

    Phuong Thanh Level 1

      But I have more question

      i can't make effect label in <repeater> forexample move and this source:

      //repeater:

      <mx:VBox x="70" y="245" width="290" height="159">
                          <mx:Repeater id="r1" dataProvider="{tintucRequest1.lastResult.tieudechinh.item}">   
                              <mx:HBox>                           
                                   <mx:Label id="tinchinh" text=">> {r1.currentItem.ND}"  useHandCursor="true" buttonMode="true" mouseChildren="false"   color="#F0DE14"
                                            fontSize="20" fontFamily="Times New Roman" fontStyle="italic"
                                              mouseOver="tinchinh_mouseOverHandler(event)"/>   
                              </mx:HBox>                   
                          </mx:Repeater>
                      </mx:VBox>


      <!----- and >

      <fx:Declarations>
              <s:Move id="TC"
                        xFrom="70"
                        xTo="80"                       
                      target="{tinchinh}"
                      />

      <!--and> in funtion:

      protected function tinchinh_mouseOverHandler(event:MouseEvent):void
                  {
                      // TODO Auto-generated method stub
                      TC.play();
                  }
      But when i mouse move label it don't run move xfrom "70 " to xTo="80"

      how do i work