2 Replies Latest reply on Sep 15, 2010 9:15 AM by learner_doug

    External jpg not loading in release build

    learner_doug Level 1

      I'm trying to load a simple jpg into an application which works fine in the development mode, but not in the release build on the remote server(embedded images work fine however).  (this also happens with swfs).  This is also happening to one of my fellow students where I'm taking a Flex 4 class. 

       

      I'm wondering if Flex simply does not actually load external swfs and jpgs unless they are embedded, or "componentized" in release builds.  Getting no errors, the app loads fine with no jpg (or swf).

       

      Thanks. 

        • 1. Re: External jpg not loading in release build
          Flex harUI Adobe Employee

          Is the path specified for the jpg valid relative to where the release SWF is

          deployed?  You can use a network monitor to see what the requested URL is.

          You can also listen for events from mx:Image and see if you are getting any.

          1 person found this helpful
          • 2. Re: External jpg not loading in release build
            learner_doug Level 1

            The path is the same as in the original "pre-release" build.  But as a test, I actually copied the jpg into the same directory as the html file and removed the relative path to see if that would help.  I understand this questioning because it does seem that the app can't "find" the jpg.

             

            I'll need to get better at listening for events coming from external resoucrses.  Currently, not sure how to address them.

             

            thanks.