4 Replies Latest reply on Sep 17, 2010 4:29 AM by Marvin Velo

    Can't build FlexPMD 1.2

    gwright10 Level 1

      I can't seem to get FlexPMD 1.2 to build with Maven.

       

      I did an export from SVN to a new directory:


      C:\>svn export http://opensource.adobe.com/svn/opensource/flexpmd/tags/1.2/ flexpmd1.2

       

      Then ran "mvn clean package" (using Maven 2.0.9 with no settings.xml and an empty local repository):

       

      C:\flexpmd1.2\flex-pmd-parent>mvn clean package

      [INFO] Scanning for projects...
      [INFO] Reactor build order:
      [INFO]   Adobe Flex PMD
      [INFO]   Adobe Flex PMD Java Parent
      [INFO]   As3 Maven plugin Utils
      [INFO]   As3 Parser API
      [INFO]   Adobe Flex PMD RuleSet test resources
      [INFO]   Adobe Flex PMD Files
      [INFO]   As3 Parser
      [INFO]   Adobe Flex PMD RuleSet API
      [INFO]   Adobe Flex PMD RuleSet
      [INFO]   Adobe Flex PMD Core
      [INFO]   Adobe Flex PMD Maven plugin
      [INFO]   Adobe Flex CPD (Copy and Past Detector)
      [INFO]   Adobe Flex CPD Maven plugin
      [INFO]   Adobe Flex Metrics
      [INFO]   Adobe Flex Metrics Maven plugin
      [INFO]   Adobe Flex PMD Flex Parent
      [INFO]   FlexUnit theme
      [INFO]   Adobe Flex PMD Flex lib
      [INFO]   Adobe Flex PMD Ruleset creator
      [INFO]   Adobe Flex PMD Violations viewer
      [INFO]   Adobe Flex PMD Flex/Java Parent
      [INFO]   Adobe Flex PMD Mac OSX Automator workflow
      [INFO]   Adobe Flex PMD Ant task
      [INFO]   Adobe Flex PMD Command line API
      [INFO]   Adobe Flex PMD Command line
      [INFO]   Adobe Flex CPD Ant task
      [INFO]   Adobe Flex CPD Command line
      [INFO]   Adobe Flex Metrics Ant task
      [INFO]   Adobe Flex Metrics command line
      [INFO]   Adobe Flex PMD All-in-one bundle
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Adobe Flex PMD
      [INFO]    task-segment: [clean, package]
      [INFO] ------------------------------------------------------------------------
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error building POM (may not be this project's POM).

       


      Project ID: org.codehaus.mojo:cobertura-maven-plugin
      POM Location: C:\Documents and Settings\<username>\.m2\repository\org\codehaus\mojo\cobertura-maven-plugin\2.2\cobertura -maven-plugin-2.2.pom

       

      Reason: Not a v4.0.0 POM. for project org.codehaus.mojo:cobertura-maven-plugin at C:\Documents and Settings\<username>\.m2\repository\org\codehaus\mojo\cobertura-maven-plugin\2.2\cobertura -maven-plugin-2.2.pom

       

      Its downloading this:

       

      <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
      <html><head>
      <title>301 Moved Permanently</title>
      </head><body>
      <h1>Moved Permanently</h1>
      <p>The document has moved <a href="https://nexus.codehaus.org/content/repositories/releases/org/codehaus/mojo/cobertura-maven -plugin/2.2/cobertura-maven-plugin-2.2.pom">here</a>.</p>
      <hr>
      <address>Apache/2.0.52 (Red Hat) Server at repository.codehaus.org Port 80</address>
      </body></html>

       

       

      Looks like the repository URL needs to be updated in the poms.