12 Replies Latest reply: Nov 8, 2011 12:48 PM by blackhalo13 RSS

    Can't disable animated zoom in CS5

    Ens0 Community Member

      Subject pretty much says it all. Photoshop is fully updated via the updater (12.0.1 x64).

       

      20" iMac

      2.66ghz

      4GB RAM

      Mac OS 10.6.4

        • 1. Re: Can't disable animated zoom in CS5
          c.pfaffenbichler Community Member

          Is »Scrubby Zoom« checked in the Options Bar?

          • 2. Re: Can't disable animated zoom in CS5
            Ens0 Community Member

            No it's unchecked. Strangely though, if I zoom using the zoom tool it's not animated but if I use the hotkey (cmd +/-) or the radial wheel on my Wacom, it is animated.

             

            Here's a few things I left out about my system:

             

            ATI Radeon HD 2600 Pro (256MB VRAM)

            Core2 Duo (2.66Ghz)

            Wacom Intuos4 Large

            • 3. Re: Can't disable animated zoom in CS5
              MTSTUNER Community Member

              Try Preferences>General and uncheck: Animated Zoom.

               

               

              MTSTUNER

              • 4. Re: Can't disable animated zoom in CS5
                Ens0 Community Member

                MTSTUNER wrote:

                 

                Try Preferences>General and uncheck: Animated Zoom.

                 

                 

                MTSTUNER

                 

                Already did that.

                • 5. Re: Can't disable animated zoom in CS5
                  MTSTUNER Community Member

                  I think what your seeing is the regular non gl zoom.

                  If you look at the zooming while using the keyboard shortcuts,

                  it's not smooth like the animated zoom is.

                   

                  If you go to Preferences>General and uncheck zoom with scroll wheel,

                  that may turn off the zooming with your Wacom radial wheel.

                   

                   

                   

                  MTSTUNER

                  • 6. Re: Can't disable animated zoom in CS5
                    Ens0 Community Member

                    No, that's actually not what I'm seeing. I'm seeing the GL, animated zoom regardless of whether or not it's disabled. I have "Animated Zoom", "Zoom with Scroll Wheel", and "Scrubby Zoom" all unchecked and it's still animated. The only thing that seems to disable animated zoom is if I turn off OpenGL altogether or if i choose the zoom tool and click to zoom. In any other circumstance the zoom is animated and nothing I've done so far has been able to disable it.

                    • 7. Re: Can't disable animated zoom in CS5
                      binarysheep Community Member

                      I have the same isue with CS5, and to make things even weirder, look at this:

                       

                      When you press Ctrl++ and Ctrl+- (plus and minus), the zoom is animated. Press Ctrl+0 (fit to screen) and it's not animated, it pops right into the size that fits.

                      When you press Ctrl+Alt++ and Ctrl+Alt+- , the zoom is not animated. And press Ctrl+Alt+0 (actual pixels), the zoom is animated again...

                       

                      It almost looks like some key's have been turned upside down.

                       

                      Edit: all zoom settings are turned off, and opengl turned on (to basic).

                      • 8. Re: Can't disable animated zoom in CS5
                        Ens0 Community Member

                        Yeah the way OpenGL interacts with zooming is highly erratic. I noticed that having the "Resize Windows To Fit" option checked on the Zoom tool's option bar disables animated zoom. Even if you have Animated Zoom enabled in the preferences, if you have Resize Windows To Fit enabled, the zoom will not animate (if you press the f key to enter fullscreen mode you'll see the effect more clearly).

                         

                        I have to say, I've been really disappointed with Photoshop from CS3 onward. The only things that really needed to be implemented were canvas rotation, faster brushes, and Cocoa / 64-bit support. But Adobe has gone about it all in the most haphazard, inefficient, and counter-intuitive way imaginable. A GPU is supposed to accelerate video performance but in Photoshop, it actually slows everything down. Unbelievable.

                        • 9. Re: Can't disable animated zoom in CS5
                          soylentdean Community Member

                          Definite bug.  I've got the same problem.  Basically forced to turn off the OpenGL stuff because of it even though there might be a thing or two I like.  I haaate the animated zoom.

                          • 10. Re: Can't disable animated zoom in CS5
                            binarysheep Community Member

                            Forgot to reply to you. Your solution with disabling "Resize windows to fit" worked for me. After I swapped two keyboard zoom shortcuts, all the important zoom keys are now behaving like I wanted, eg. no animated zoom With only one of the four still animating, the Resize To Fit shortcut, but I rarely use that anyway. So thanx a lot, pall !!

                             

                            I agree, I was a happy CS2 user before I got CS5. Always fast, no stupid nonsense. The gpu should indeed be used to accelerate the workflow and performance, not make it more fancy, blergh... I had such high regards towards Adobe, but it's slowly dissipating with their latest products, pity. I really don't get why almost everything in today's world has to look shiny and all spiffed up, sacrificing usability...

                            • 12. Re: Can't disable animated zoom in CS5
                              blackhalo13 Community Member

                              Sorry for reviving an old thread, yet again...

                              but for posterity sake (read: the next time I re-install Photoshop and have to go looking for this solution)...

                              here's the correct answer:

                               

                              If you want to reverse the key commands easily, simply check "ON" the general preference "Zoom Resizes Windows"...

                              don't ask me the how's and why's of it... but it works.

                               

                              Also, in the link above there's a comment on that page that was interesting:

                               

                              Using "CTRL+Spacebar" and "ALT+Spacebar" temporarily switches to the Zoom +/- tool...

                              which is actually more efficient than using the key commands (since your right hand is likely on the mouse already, and you need to press CTRL with your left hand anyway).

                               

                              I like it, smarter... unfortunately the trick now;

                              is breaking my habit of using "CTRL++/-" for zooming.

                               

                              Anyway, there's some answers.