2 Replies Latest reply on Oct 7, 2010 1:59 AM by Praveen Hyd

    Fscommand "exec" doesn't work in Mac (Flash Player 10.1)

    Praveen Hyd

      Hi All,

       

      I am trying to launch an external application using fscommand in Mac ('fscommand' works fine on Windows). I have done following things to make it work:

      1. Written an apple script to launch a pdf and saved it as "test.app"
      2. I copied "test.app" to "fscommand" directory. (fscommand is a directory under 'flash projector.app')
      3. Tried to launch the "test.app" using fscommand, as shown below:

                  fscommand("exec", "test.app");   

       

      But, my efforts went in vain. It did not work. I even tried to copy "fscommand" dir to "Flash Debugger Player.app/Contents/MacOS/", but still I can't make it work.

       

      More Info:

      Mac version: Mac OS X 10.6.2

      Hardware: Intel Core duo 2

      Flash Player Version: 10.1 (standalone projector)

       

      Is it something I am missing or is it a bug in Flash Player 10.1? Does anybody could make it work; Please let me know!