5 Replies Latest reply on Nov 1, 2010 6:24 AM by Dmiyake

    9.01 CF Update Fails

    WestSide Level 1

      Hi,


      I'm trying to update ColdFusion 9 to 9.01 and my installation fails.  I looked in the log file and I saw one non-fatal error.  The messages are below.  I can't figure out how to resolve it though.  Any ideas?  I've done this on another server and no problems.

       

      ANT Script Error:
                                Status: ERROR
                                Additional Notes: ERROR - cfmx-patch-move-files-all.xmlFailed to copy C:\ColdFusion9\lib\cfperfmon_9.dll to C:\Windows\system32\cfperfmon_9.dll due to C:\Windows\system32\cfperfmon_9.dll (The process cannot access the file because it is being used by another process)

       

       

      Copy Folder:              Destination: C:\ColdFusion9\bin
                                Status: WARNING
                                Additional Notes: WARNING - There was a problem copying C:\ColdFusion9\updater_backup\bin

       

      -------------------

       

      Any help appreciated.

       

      Thanks,

        • 1. Re: 9.01 CF Update Fails
          Adam Cameron. Level 5

          Well... did you check what it mentions?  Is something else holding that file open?

           

          Sounds to me like you've got some monitoring software running whilst you're doing this upgrade...

           

          --

          Adam

          • 2. Re: 9.01 CF Update Fails....turn off WMI Service!
            jsiano

            Dear Westide and (others).

            I was frustrated over this same problem as you identified and actually was just about to engage technical support.  The answer is you need to disable Windows Management Instrumentation service (WMI).  I'm using Win2k8 R2-64 bit and the instructions provided in the Adobe PDF call this out only for Windows 2003.  I turned that off and it worked finally!  Prior to that, I must have re-run that installeer 4 times with the sames exact file name and choke point you encounter.

             

            I had even disabled all the services and rebooted the service with them all off -- but not WMI!   Note-- when you kill the WMI process, you may take down some other dependent services such as IP Helper and VMWARE upgrade tools support.

             

            Try that and I bet you will be as suprised as me.  Google the error and your posting is the only thing that comes up on the entire web.

             

            Good luck!

            Sincerely,

            Jim

            • 3. Re: 9.01 CF Update Fails....turn off WMI Service!
              Jeff Coughlin Level 1

              Jim,

               

              That one was getting me too.  Your comment helped.  I'm using Win2k8 R2 64-bit as well and disabling the WMI service fixed my problem even though the docs say it's only needed for Win2k3.  However, after doing a few tries of the upgrade I think the upgrade installer borked my CF install (I couldn't even rollback to cf9.0).

               

              So, to resolve it I:

              - backed up all my neo*.xml files in the {cfroot}/cflib folder

              - Uninstalled CF9 (from {cfroot}/uninstall folder)

              - renamed old cfroot folder to ColdFusion9_old (for no particular reason other than to keep logs and undeliv mail files)

              - reinstalled cf9.0

              - upgraded to cf9.0.1 (successfully)

              - copied back the neo*.xml files and restarted cf (this gave me back all my cf configs like mappings and DSNs).

               

              The key to doing what Jim suggested was to not only turn off the WMI service, but to actually disable it (as Jim mentioned).  I found that if I just stopped the WMI service, the upgrader would still fail because the service would somehow get restarted.  Just don't forget to re-enable the WMI service once CF is upgraded and running smooth again.

              • 4. Re: 9.01 CF Update Fails....turn off WMI Service!
                WestSide Level 1

                Hi,

                 

                Thanks, I didn't try that but will definitely take note.  I actually ended up reinstalling ColdFusion 9, then immediately running the update and it worked fine.  Not ideal, but it worked.

                 

                -Westside

                • 5. Re: 9.01 CF Update Fails
                  Dmiyake

                  Hi,

                   

                  The trick for me was to disable both WMI and SNMP.  I searched for the DLL using Process Explorer (http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx), saw that it was in use by SNMP, stopped SNMP, re-ran the installer, and it worked properly.

                   

                  Regards,

                   

                  Dylan