0 Replies Latest reply on Sep 23, 2010 5:59 PM by holodog

    CS4 hanging at launch, tracing garbage

    holodog

      I recently received files from another developer that wouldn't launch on my computer. The files were created on OSX/CS4, and I am working on Win7/CS4. The files worked fine when I tried them on my Mac. Now the same problem seems to happen on all files I try to open.

       

      What happens is CS4 takes a very long time to open FLAs. Sometimes it crashes. When it does manage to open the file, exporting the swf (ctrl+enter) hangs the system. On the few times it manages to complete the export, it traces out what appears to be a memory dump, like so:

       

       

      @124 def   @114 spans call

          22254681  mov   edi, eax

                               alloca 4 at 140 for @124 activation.size 144

                                 stacksize 144 entries 15

                                 -24(ebp) (6-202) alloc

                                 -52(ebp) (7-202) alloc

                                 -100(ebp) (8-202) alloc

                                 -104(ebp) (0-203) arg 

                                 -108(ebp) (1-203) arg 

       

       

       

      I have completely re-installed CS4 and the problem does not go away. I also tried using the CS5 clean uninstall tool before re-installing. I have tried restoring default preferences by clearing the relevant registry keys to no avail.

       

      Suggestions?