2 Replies Latest reply on Sep 27, 2010 3:30 PM by areohbee

    Plugin problem with 3.2, works ok with 2.7 - solved (sort of...)

    _KPa Level 1

      Hi,

       

      Just to check if anyone else is having same issue, or may even have solved it:

       

      Metadata Wrangler version 20100829.68 that is working fine with LR 2.7 does not work with 3.2. The problem is that it gets stuck, the jpg is exported but metadata wrangler seems not to execute. However, it reacts to cancel nicely. If I do not cancel it, it seems to run forever without processing metadata.

       

      Same installation for that plugin runs ok in same operating system istallation with LR 2.7, but not with 3.2. Re-installing plug-in does not help, and user permission are ok. No errorlogs are produced. Previous version of plugin exhibits the same behaviour.

       

      Operating system is Windows 7 Pro 64bit.

       

      I have dropped a note on this to Jeffrey's blog, but unfortunately he has not yet responded to it.

       

      Can anyone give a hint how to troubleshoot this further? Is this operating system related (if it is, why 2.7 works ok)?


      Updated on 26th of September: I did test with a machine running Windows XP 32bit with both LR 3.2 and 2.7.Again, with LR 3.2 hangs, and with 2.7 everything works ok. I did also send the update to plugin author, but in the meantime all hints for troubleshooting would be welcome, unless this is known issue with LR 3.2 SDK? Based on the updated test, I would say that this is not an operating system issue, nor the 32 vs 64 bit issue.

       

      I also updated the subject line better to describe the issues.

       

      Regards,

      /KPa

        • 1. Re: Plugin problem with 3.2, works ok with 2.7 - solved (sort of...)
          _KPa Level 1

          Hi again,

           

          I'll add the solution myself. I also informed the plugin author about the solution.

           

          It appears that the deletion of the LR preferences file did solve the problem in both of the computers I have tested and repeated the problem.

           

          Because everything else was and still is working ok, I could not imagine that this could be LR-preferences related issue. Now, as I had totally run out of ideas how to troubleshoot this further I decided to test deleting the preferences as a last "desperate" measure. And to my surprice that solution did work both on Windows 7 pro 64bit and Windows XP 32bit systems. I must admit that I'm buzzled.

           

          So, instead of the plugin issue this might be related LR 3.2 update or some SDK bug introduced in 3.2? Thus I'm reporting my solution to the SDK forum.

           

          Regards,

          KPa

          • 2. Re: Plugin problem with 3.2, works ok with 2.7 - solved (sort of...)
            areohbee Level 5

            KPa,

             

            Amazing sometimes how things seemingly unrelated can be related, especially when it comes to sofware.

             

            Thanks for reporting.

             

            Rob