1 Reply Latest reply on Sep 25, 2010 9:57 AM by filon12

    ZendAMF service call doesn't trigger fault or result events

    filon12

      I have developed a an applicaton that fetches data using Zend Amf functionality.

       

      At first the app worked just fine.

       

      Today, I run the app again AND.... the DataGrid that was bound to the "lastresult" of the service call just stopped showing the data for no apperent reason.

       

      I troubleshooted the issue:

       

      1. Testing the service call itself returns the correct result.

      2. Network monitor also show the correct data returning to the client.

      3. I have attached the fault and result event handlers to the serice call object but neither of them are called when the service is called.

      4. I have removed the service and recreated it again but the behaviour has not changed.

      5. I have bound another service call to the datagrid and only one data element out of maybe 10 is displayed correctly, the resest of them are all set to null

       

      What in the world could be causing this?

       

      All the other apps on my machine seem to be working just fine?


      Please help,

        • 1. Re: ZendAMF service call doesn't trigger fault or result events
          filon12 Level 1

          Ok I found the solution, or rather, the cause of this.

           

          The service call had paging enabled and, unfortunatly, the unique property in the series of object returned turned out to be NOT unique.

           

          This must have confused the paging code and the datagrid was just giving me nothing or junk.

           

          I still find it strange that those event handlers wouldn't fire eventhough the data was coming back to the client as expected.