4 Replies Latest reply on Sep 27, 2010 2:20 PM by Captiv8r

    Project .htm File not being Generated

    valeried21

      I have a robohelp project created using x5 (webhelp project).  However, when I generate the files, the project .htm file is not being generated. Also, the "whdata," "whgdata," and "wxhdata" folders are not being created.  Is there a setting in Robohelp that will enable the generation of these files?  I have worked on previous robohelp projects, and all have included these files for the webhelp output.  The developer I work with cannot put the help system up on the application without these files.

       

      Thanks.

        • 1. Re: Project .htm File not being Generated
          Captiv8r Adobe Community Professional & MVP

          Welcome to our community

           

          You may need to check your permissions. Has RoboHelp been run at least once as an administrator with admin privileges on the PC? I have worked with folks before that were unable to create WebHelp. It turned out their PCs were locked down too tight and as a result, RoboHelp couldn't do it's thing when it went to generate WebHelp. It would create CHM files just fine, but WebHelp flopped.

           

          So have your IT folks log in as an admin and see if RoboHelp begins working. If so, you have proven to them that they need to relax the settings a bit.

           

          Cheers... Rick

           

           

          Helpful and Handy Links

          RoboHelp Wish Form/Bug Reporting Form

          Begin learning RoboHelp HTML 7 or 8 moments from now - $24.95!

          Adobe Certified RoboHelp HTML Training

          SorcererStone Blog

          RoboHelp eBooks

          • 2. Re: Project .htm File not being Generated
            valeried21 Level 1

            Thanks Rick. I don't think it's security permissions. I'm the admin and the only one in the company that uses Robohelp and have created about 20 help systems and all have worked fine. I didn't change any settings so am confused how it is not generating the essential files. How can I access the administrative settings that may be preventing this?

             

            Thanks,

            Val

            • 3. Re: Project .htm File not being Generated
              Captiv8r Adobe Community Professional & MVP

              Hi Val

               

              I'm not sure how to check permissions. I'm only aware that they play a role.

               

              So now that we have more information...

               

              I once had WebHelp spontaneously refuse to generate. I never did figure out why. But I assume it was something to do with installing another software package. In my case, I had to reinstall something called an "XML Parser". One of my IT peeps did it for me.

               

              Here is what I would try. Create a totally new project somewhere. Just with one or two topics in it. Try generating that and see if it creates the WebHelp or if it behaves the same way. If it successfully generates WebHelp, you know that the issue is specific to the project you have and you can focus there. But if a brand new project fails, well, the problems go deeper.

               

              If the new project generated okay, try closing the project, then deleting the .CPD file. Then re-open the project.

               

              If the new project failed, time to get your IT folks involved. Maybe reinstall RoboHelp. Definitely check the settings. Sometimes they institute restrictions without telling you about it.

               

              Cheers... Rick

               

               

              Helpful and Handy Links

              RoboHelp Wish Form/Bug Reporting Form

              Begin learning RoboHelp HTML 7 or 8 moments from now - $24.95!

              Adobe Certified RoboHelp HTML Training

              SorcererStone Blog

              RoboHelp eBooks

              • 4. Re: Project .htm File not being Generated
                valeried21 Level 1

                Thanks for the help.  Robohelp gives me the confirmation box that the webhelp has been generated successfully, but the project HTM file and the three folders are not there. So it's not like it's refusing to generate. It's totally boggling me as to why the files aren't being generated.  I already tried generating a simple two-topic project and it performed the same.  I may have to reinstall Robohelp, but I'll try the XML parser thing you mentioned. But an interesting thing is that I'm using Robohelp x5 and one of the developers here downloaded the trial version of Robohelp 7 and generated my files in there and it worked correctly. So it may have something to do with my version/settings.

                 

                Thanks again,

                Val