11 Replies Latest reply on Sep 19, 2017 7:20 AM by Szalam

    AE Puppet Tool Move Problem


      Does anyone know why the puppet tool would stop moving in both x,y directions and be confined to just moving on the y directions?


      I've worked with the puppet tool and this same humanoid character for some time now. Just today about halfway through an animation the characters puppet points stopped being able to move in all directions and were confined to moving up and down along an unseen path.


      I tried recreating the asset and it still comes to the same issue.


      Could I have accidentally hit something to make the points be confined to a singular direction?


      Any help is appreciated.

        • 1. Re: AE Puppet Tool Move Problem
          Mylenium Most Valuable Participant

          Are you perhaps using starch? Two pins in specific positions next to each other? Pins only moving one way usually are an indication that you have created a "super-rigid" region somehow by placing pins in an unfavorable pattern. That is in terms of the underlying algorithm correct when it tries to avoid overlaps/ intersections, but naturally will not always be desirable. Hard to say more than that without seeing the project...



          • 2. Re: AE Puppet Tool Move Problem
            natedodge Level 1

            Sadly no starch pins are being used.


            I started work today and tried going back to a previously okay version of the comp and now that comp has been corrupted as well.


            I'm going to see if I can get a screen capture of what I am working with so it will shed some more light on the situation that is hard to describe.

            • 3. Re: AE Puppet Tool Move Problem
              natedodge Level 1

              Here's a video describing the issue with the tool




              Thanks for the help.

              • 4. Re: AE Puppet Tool Move Problem
                Todd_Kopriva Level 8

                If you email me the project, I'll have a look. My address is

                kopriva -at- adobe -dot- com

                • 5. Re: AE Puppet Tool Move Problem
                  Mylenium Most Valuable Participant

                  I still think you have an issue with teh deformations accumulating unfavorably, so I second Todd's suggestion of sending the project. I also noticed from the video, that everything seemed ratehr low-res, so you might consider to in fact use a larger version of the creature and then scale it down after you have animated it. I could imagine that because of the smallness, you might cause internal math errors, where AE can no longer keep trhe folding of the pixels straight. You can only stretch a pixel so far before they break, if you get my meaning....



                  1 person found this helpful
                  • 6. Re: AE Puppet Tool Move Problem
                    natedodge Level 1

                    Thank you both.


                    I did send Todd the project file.


                    I had previously been working in a much larger format of the creature and it lead to slowing of AE and the computer due to the size so at the start of this current episode I decided it would be good to keep it smaller.


                    I have currently recreated the project from scratch and things to be coming along alright but I'm still concerned that this could happen again.


                    Let me know if you come up with any ideas after seein the project.

                    • 7. Re: AE Puppet Tool Move Problem
                      Todd_Kopriva Level 8

                      I'll have a look at the project today.

                      • 8. Re: AE Puppet Tool Move Problem
                        Todd_Kopriva Level 8

                        Well, that certainly is a fascinating bug.


                        First, let me give you a couple of ways to make things work:


                        The bug only seems to affect dragging of the pins in the Composition panel. If you drag the pins in the Layer panel, it works OK. So, if you dock a Layer panel next to your Composition panel, you can finish your animation that way, dragging pins in the Layer panel and seeing the result in the Composition panel.


                        Also, it seems that this isn't related to where in the timeline you are, but where in space the body (your master layer to which the limbs are parented) is. When the body is way to the right, that's when things fail.


                        Rather than wait until I've got things perfectly isolated and well understood, I thought that I'd send this update to give you some clues about how to continue with your work. The next step is for me to work with one of the testers to determine what's _really_ going on.

                        1 person found this helpful
                        • 9. Re: AE Puppet Tool Move Problem
                          natedodge Level 1

                          Thanks for the response.


                          I did a new comp and matched it to the last frame of the corrupted comp so I could continue animation.


                          I will try using the Layer window if the problem occurs again. Though it will be strange to be pushing points not directly on the character.

                          • 10. Re: AE Puppet Tool Move Problem
                            _benju Level 1

                            I have exactly the same problem in AE CC2017.2 now. Editing in the layer previw ist  working, but on the comp preview I only can move it horizontally. If you want I can send you the project for bug tracking.


                            But it only happens if I have a very small scaling. The layer I was applying the marionette was scaled down to 3%. If I scale it back up to e.g. 20%, I can also move the marionette pin again in x and y axis. So for me the solution was to prescale the footage down.

                            • 11. Re: AE Puppet Tool Move Problem
                              Szalam Adobe Community Professional & MVP

                              I'm glad you found a solution.

                              Don't bother sending anything to Todd as he no longer works for Adobe.

                              You can, however, file a bug report here: www.adobe.com/go/wish and let them know you're willing to share a file (heck, you can even put a dropbox link to the problematic project file in your bug report). Bug reports filed there go directly to the team that works on After Effects, so it's a pretty good way to call attention to problems!