1 Reply Latest reply on Oct 6, 2010 4:32 PM by tzeng

    Air application compiling but when run it cannot find flash.system.SystemUpdater

    givemeascreenname2

      Hi all,

       

      I am trying to create an OSMF Player playing Flash Access 2.0 DRMed content in an Air application and I am having a bit of trouble.

       

      I am developing in the latest release of FlashDevelop, 3.3.0, using the Air AS3 Projector project template, and I am compiling against the Flex 4.1 SDK and I am targeting Flash Player 10.1. I am also using the Flash 10.1 version of the OSMF.swc.

       


      So, the problem I am seeing is that when the drm video content is loaded the OSMF player sees the need to update the player and so instantiate the flash.system.SystemUpdater class. At this point I see the following runtime error when running the application through adl.exe

       

      VerifyError: Error #1014: Class flash.system::SystemUpdater could not be found.
      
          at org.osmf.elements::LightweightVideoElement/createDRMTrait()
          at org.osmf.elements::LightweightVideoElement/onStatus()
      

       

      Just to check that was the real error that was occuring I made a completely new Air project with a single line of code:

       

      var su:SystemUpdater = new SystemUpdater();

       

      which when run using the adl.exe tool results in the error

       

      VerifyError: Error #1014: Class flash.system::SystemUpdater could not be found.
      
          at runtime::ContentPlayer/loadInitialContent()
          at runtime::ContentPlayer/playRawContent()
          at runtime::ContentPlayer/playContent()
          at runtime::AppRunner/run()
          at global/runtime::ADLEntry()
      

       

       

      Now I can't quite work out why I should see this error. The application compiles absolutely fine, and I have taken a look inside airglobal.swc and I can see the flash.system.SystemUpdater class is included, so this explains the fact that it compiles, but why is it saying this does not exist at runtime?

       

      I have tried running with the Flex 4.1 SDK's version of adl, I have also tried running it against the Air 2 SDK version of adl and have the same problem.

       

      When I package the content as an Air app, install and run it I obviously do not see the error message anymore, but I log some info to the screen that strongly suggests the same error is being thown. I also have the latest version of Air installed on my machine, todays release, but it did not work yesterday either on the previous release.

       

      Finally, if I drag the generated swf into a browser window it works as expected.

       

      If anyone has any ideas of what I have missed I would love to here them as I am beginning to go a little crazy!

       

      Cheers

      Mike