5 Replies Latest reply on Feb 25, 2015 4:51 PM by 32165498732165498

    Why doesn't my flash builder plugin work even when i have a valid license?

    jiflex

      Hi Experts!

       

      This is the second time this is happening to me.

       

      I have a valid Flash Builder 4 license. I had installed flash builder plugin over Helios 2 months ago. It worked fine until today. But now I am not able to open mxml or .as files.

      This is the error I get.

      java.lang.NullPointerException

      at org.eclipse.ui.part.MultiPageEditorPart.createContainer(MultiPageEditorPart.java:284)

      at org.eclipse.ui.part.MultiPageEditorPart.createPartControl(MultiPageEditorPart.java:347)

      at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)

      at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)

      at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)

      at org.eclipse.ui.internal.EditorAreaHelper.setVisibleEditor(EditorAreaHelper.java:271)

      at org.eclipse.ui.internal.EditorManager.setVisibleEditor(EditorManager.java:1429)

      at org.eclipse.ui.internal.EditorManager$5.runWithException(EditorManager.java:942)

      ...

      ...

       

       

      Here's what led to this problem. This is my office laptop and the license was purchased by the company.

       

      1. I had to change my SSO password as it was about to expire. We use Lotus notes (built on eclipse) to do this.

      2. I opened eclipse and tried to open an mxml file. And this is what I get.

       

      About 2 months ago, I had exact same problem. I had to use a new laptop to start working again.

       

      Please help me.

        • 1. Re: Why doesn't my flash builder plugin work even when i have a valid license?
          Unni Gopinathan S Adobe Employee

          Hi,

           

          Can you please post the .log file from your workspace.

          • 2. Re: Why doesn't my flash builder plugin work even when i have a valid license?
            jiflex Level 1

            !SESSION 2010-10-12 13:34:33.875 -----------------------------------------------

            eclipse.buildId=M20100909-0800

            java.version=1.6.0_21

            java.vendor=Sun Microsystems Inc.

            BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

            Framework arguments:  -product org.eclipse.epp.package.jee.product

            Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product

             

            !ENTRY org.eclipse.ui 4 0 2010-10-12 13:36:38.812

            !MESSAGE Unhandled event loop exception

            !STACK 0

            org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException))

            at org.eclipse.swt.SWT.error(SWT.java:4083)

            at org.eclipse.swt.SWT.error(SWT.java:3998)

            at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:137)

            at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4041)

            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3660)

            at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)

            at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)

            at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)

            at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)

            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

            at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)

            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)

            at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)

            at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)

            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)

            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)

            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

            at java.lang.reflect.Method.invoke(Unknown Source)

            at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)

            at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)

            at org.eclipse.equinox.launcher.Main.run(Main.java:1407)

            Caused by: org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)

            at org.eclipse.swt.SWT.error(SWT.java:4083)

            at org.eclipse.swt.SWT.error(SWT.java:3998)

            at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:137)

            at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4041)

            at org.eclipse.swt.widgets.Display.msgFilterProc(Display.java:3375)

            at com.adobe.flexide.nativelibs.Headlights.AdobePIPInitialize(Native Method)

            at com.adobe.flexbuilder.ui.UIPlugin$1.run(UIPlugin.java:139)

            at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

            at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)

            ... 22 more

            Caused by: java.lang.NullPointerException

            at org.eclipse.mylyn.internal.monitor.ui.ActivityContextManager$3.run(ActivityContextManager .java:110)

            at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

            at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)

            ... 28 more

             

            !ENTRY org.eclipse.ui 4 4 2010-10-12 13:36:52.546

            !MESSAGE Unable to find view with id: com.adobe.flashbuilder.analytics.ui.SiteCatalystView, when creating perspective com.adobe.flexbuilder.editors.mxml.ui.perspectives.development

             

            !ENTRY org.eclipse.ui 4 0 2010-10-12 13:37:22.906

            !MESSAGE Unable to create editor ID com.adobe.flexbuilder.editors.mxml.MXMLEditor: An unexpected exception was thrown.

            !STACK 0

            java.lang.NullPointerException

            at org.eclipse.ui.part.MultiPageEditorPart.createContainer(MultiPageEditorPart.java:284)

            at org.eclipse.ui.part.MultiPageEditorPart.createPartControl(MultiPageEditorPart.java:347)

            at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)

            at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)

            at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)

            at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:313)

            at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:180 )

            at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFo lder.java:270)

            at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder .java:65)

            at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStack Presentation.java:473)

            at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1254)

            at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1207)

            at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1606)

            at org.eclipse.ui.internal.PartStack.add(PartStack.java:497)

            at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:103)

            at org.eclipse.ui.internal.PartStack.add(PartStack.java:483)

            at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:112)

            at org.eclipse.ui.internal.EditorSashContainer.addEditor(EditorSashContainer.java:63)

            at org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorAreaHelper.java:225)

            at org.eclipse.ui.internal.EditorAreaHelper.addEditor(EditorAreaHelper.java:213)

            at org.eclipse.ui.internal.EditorManager.createEditorTab(EditorManager.java:778)

            at org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(EditorManager.java:677)

            at org.eclipse.ui.internal.EditorManager.openEditor(EditorManager.java:638)

            at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2860)

            at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2768)

            at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2760)

            at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2711)

            at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)

            at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2707)

            at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2691)

            at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2674)

            at org.eclipse.ui.ide.IDE.openEditor(IDE.java:683)

            at com.adobe.flexbuilder.project.ui.FlexProjectUI.openEditor(FlexProjectUI.java:277)

            at com.adobe.flexbuilder.project.ui.FlexProjectUI.access$2(FlexProjectUI.java:272)

            at com.adobe.flexbuilder.project.ui.FlexProjectUI$1.runInUIThread(FlexProjectUI.java:189)

            at org.eclipse.ui.progress.UIJob$1.run(UIJob.java:95)

            at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

            at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)

            at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4041)

            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3660)

            at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)

            at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)

            at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)

            at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)

            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

            at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)

            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)

            at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)

            at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)

            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)

            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)

            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

            at java.lang.reflect.Method.invoke(Unknown Source)

            at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)

            at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)

            at org.eclipse.equinox.launcher.Main.run(Main.java:1407)

            • 3. Re: Why doesn't my flash builder plugin work even when i have a valid license?
              jiflex Level 1

              Exactly after 2 months, this happened to me again. My company has bought a valid license from Adobe and this keeps happening every 2 months with me. This is the 3rd or 4th time this is happening. It is killing my productivity.

               

              Every time this happens I am forced to format my machine and install all the apps again which takes  a whole day or two.

              • 4. Re: Why doesn't my flash builder plugin work even when i have a valid license?
                pelachile

                Try switching to a new workspace. Goto File->Switch Workspace->Other. Then select a new workspace without any metadata in it.

                • 5. Re: Why doesn't my flash builder plugin work even when i have a valid license?
                  32165498732165498

                  I had this same issue and deleting the metadata folder fixed it