0 Replies Latest reply on Oct 12, 2010 9:32 AM by zesme

    I *think* this is a bug...

    zesme

      Hello,

       

      Ah, well, I don't really know what to do... if I should stick to what I've got, restart it all over again, but I have the slight hope that Adobe might be able to help me, at least a little. I don't want to recode this all over again...

       

      Anyways, I'm coding this game... my first MMOG in fact, I decided to code my own server, using C#. Yesterday, I had got an incredible streak of luck and I managed to finish movement, it was crappy, really laggy, but I was so happy, like any developer would get when they achieve something. I felt I was going to, at least once, do something decent, build a nice game, just for fun.

       

      However, I lost all of my hope today, when about 1 hour ago, I encounter myself with one of the friendliest flash messages I've seen:

       

      "Can not save file to "C://[..]" please try at another location or with a different filename"

       

      All right, I saw it, and I instantly realized that I was going to get in some deep, horrible, problem. But, I had confidence in my beloved Flash CS5 (uh-oh) and I tried saving it one folder up (at the parent folder). error again. I change the filename. Error again. I desperately try to save it as an .xfl, or a CS4 .fla, but this only worsened the situation: My .fla, disappeared.

       

      OK - I though - Flash is still open, I can try to save it.

       

      But seems I was with the worse of my luck: Visual Studio's Just-in-time debugger pops up, saying that an "unhandled win32 occurence occured in Flash.exe" and asked me with which debugger I wished to debug the broken program. I was now sure, I had lost a load of work.

       

      I've tried a recovering lost files programs, to try to see if I regained the lost .fla, but not much hope. I still have the decompiled version, but as you know, it is not as good as the fresh and normal fla...

       

      Anyone has a suggestion? I just can't believe this happened...

       

      Thanks in advance,

       

      Lucas