0 Replies Latest reply on Oct 13, 2010 6:17 AM by nafis

    Deploying Flash Builder 4 /Zendframwork project to live server issue

    nafis

      Hi Guys,

       

      I am getting seriously annoyed trying to deploy my Flash Builder 4/Zendframwork to live server. I copied my "projectName-debug " and  Zendframwork to my server root which is : "http://www.mysitename.com", then I changed the amf_config.ini file to reflect the changes.

       

      [zend]

      ;set the absolute location path of webroot directory, example:

      ;Windows: C:\apache\www

      ;MAC/UNIX: /user/apache/www

      webroot =http://www.mysitename.com

       

      ;set the absolute location path of zend installation directory, example:

      ;Windows: C:\apache\PHPFrameworks\ZendFramework\library

      ;MAC/UNIX: /user/apache/PHPFrameworks/ZendFramework/library

      zend_path =/ZendFramework/library

       

      [zendamf]

      amf.production = true

      amf.directories[]=projectName-debug/services

       

      and what I get is the following error:

       

      Send failed

      Channel.Connect.Failed error NetConnection.Call.BadVersion: : url: 'http://www.mysitename.com/projectName-debug/gateway.php'.

       

      and when I call gateway.php directly I get the following error:

       

      Warning: require_once(Zend/Loader/Autoloader.php) [function.require-once]: failed to open stream: No such file or directory in /home/mysitenamep/public_html/projectName-debug/gateway.php on line27

       

      Fatal error: require_once() [function.require]: Failed opening required 'Zend/Loader/Autoloader.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/ZendFramework/library') in/home/mysitenamep/public_html/projectName-debug/gateway.php on line 27

       

       

      Any idea guys where the hitch is??

       

      Nafis