4 Replies Latest reply on Jan 7, 2012 3:24 PM by meRocioG

    "Place" command does not work

    dean@transcon

      Hi,

       

      I changed some Applescripts over to InDesign CS5 from CS3 and now they do not work. Basically all the Applescript does is place a graphic in a rectangle and size it to fit. The problem is that I keep getting an error that says, ...

       

      Adobe InDesign CS5 got an error: "Macintosh HD:Users:User:Desktop:untitled folder:1023SW.tif" doesn’t understand the place message.

       

      I get the exact same error when I run the "Image Catalogue" script that came with Adobe InDesign CS5. The script does everything but place the image. It works just fine in CS3.

       

      Can anyone please help me with this? A sample of the script is below. This is the one that comes with CS5 but it does not work

       

      set myFile to item myCounter of myFiles
                  set myRectangle to rectangle myCounter of myDocument
                  tell myRectangle
                      set myGraphic to place (myFile as string)
                      --The place command returns a list, so get the
                      --first item of the list.
                      set myGraphic to item 1 of myGraphic
                      set label to myFile as string
                      if myFitProportional is true then
                          fit given proportionally
                      end if
                      if myFitCenterContent is true then
                          fit given center content
                      end if
                      if myFitFrameToContent is true then
                          fit given frame to content
                      end if
                  end tell

       

      Any help would be appreciated.