1 Reply Latest reply on Jul 5, 2012 5:12 PM by mughal007

    Problem deleting an item in FB4+php+zend

    bobba1 Level 1

      Hello, I have developed an app on my local machine in FB4 using wamp server as the localhost server, and using the zend framework that comes with FB4 to autogenerate the php services for my app. I have been able to get several functions working -- 'getall' and 'create'. But I am having problems getting the "delete" method to work. I am not getting any compiler errors, but I am getting the following runtime error when I try to delete an item by calling the delete method ... This is the error message I am getting: ArgumentError: Attempt to use managed delete method with an item that is not managed on this client: whirlpool_interview_managementRPCDataManager.(Object)#0   index = 4 at mx.data::ManagedOperation/deleteItemProxy()[C:\depot\DataServices\branches\lcds31_final\f rameworks\projects\data\src\mx\data\ManagedOperation.as:477] at mx.rpc.remoting::Operation/send()[E:\dev\4.x\frameworks\projects\rpc\src\mx\rpc\remoting\ Operation.as:212] at _Super_WhirlpoolinterviewmanagementService5/deleteWhirlpool_interview_management()[C:\Use rs\bob avena\Adobe Flash Builder 4\brandchek_whirlpool_1\src\services\whirlpoolinterviewmanagementservice5\_Super_Whirlpoo linterviewmanagementService5.as:276] at brandchek_whirlpool_2/button_clickHandler()[C:\Users\bob avena\Adobe Flash Builder 4\brandchek_whirlpool_1\src\brandchek_whirlpool_2.mxml:128] at brandchek_whirlpool_2/__button_click()[C:\Users\bob avena\Adobe Flash Builder 4\brandchek_whirlpool_1\src\brandchek_whirlpool_2.mxml:429] I found a few references to this error message when I googled it, but the fixes seem to refer to enabling data management (which is already enabled). Has anyone ever encountered an error message like this ("attempt to use managed delete method with an item not managed on the client (database)") when trying to execute the "delete" method? I have tried to use the delete method in several different ways, including just simply selecting an item from the datagrid and then calling a delete methid from a service call -- but no matter what I do, I keep getting this error message. Any thoughts would be appreciated. Thank you, Best, Bob

        • 1. Re: Problem deleting an item in FB4+php+zend
          mughal007

          hi bobba1,

           

          you might need to change the input type on Delete method of your service.

          the same problem i was facing.

          the delete method creates with its by default input type "object"

           

          go to your delete method>> right click >> configure input type >> Select Type >> [exactly the same type of your primary key of your DB Table]

           

          - you might had solved this problem a long time back, im posting it for new users whoever would be having the same issue-