22 Replies Latest reply on May 25, 2011 10:57 AM by zenocon

    adt package fails on Linux w/no information

    zenocon

      Hi, I have a project setup and am building native installers happily on both Win7 and Mac OS X using ant and flexTasks.jar.

       

      The Flex SDK version is 4.1.0.16076

       

      adt version "2.0.2.12610"

       

      When I run the build on Ubuntu 10.04, It compiles and builds a .swf, but then the native package installer fails with this:

       

      installer:

           [exec] Current OS is Linux

           [exec] Executing '/home/davis/flex-sdk//bin/adt' with arguments:

           [exec] '-package'

           [exec] '-storetype'

           [exec] 'pkcs12'

           [exec] '-keystore'

           [exec] 'cert/cert.p12'

           [exec] '-storepass'

           [exec] 'secret'

           [exec] '-target'

           [exec] 'native'

           [exec] '/home/davis/git/biblioflip/biblioflip-ui/installer/biblioflip-setup.deb'

           [exec] '/home/davis/git/biblioflip/biblioflip-ui/src/biblioflip-app.xml'

           [exec] '-C'

           [exec] '/home/davis/git/biblioflip/biblioflip-ui/bin-debug'

           [exec] 'biblioflip.swf'

           [exec] 'biblioflip-webapp.jar'

           [exec] 'biblioflip_logo_16x16.png'

           [exec] 'biblioflip_logo_32x32.png'

           [exec] 'biblioflip_logo_48x48.png'

           [exec] 'biblioflip_logo_128x128.png'

           [exec] 'ddl/'

           [exec]

           [exec] The ' characters around the executable and arguments are

           [exec] not part of the command.

           [exec] Invalid AIR file

           [exec] Result: 12

      I guess the only thing it references is

      12

      Invalid input

      Verify file paths and other arguments passed to ADT on the command line.

      I tried running adt itself with all the same params.  It looks like this:

       

      /home/davis/flex-sdk/bin/adt -package -storetype pkcs12 -keystore cert/cert.p12 -storepass secret -target native /home/davis/git/biblioflip/biblioflip-ui/installer/biblioflip-setup.deb /home/davis/git/biblioflip/biblioflip-ui/src/biblioflip-app.xml -C /home/davis/git/biblioflip/biblioflip-ui/bin-debug/ biblioflip.swf biblioflip-webapp.jar biblioflip_logo_16x16.png biblioflip_logo_32x32.png biblioflip_logo_48x48.png biblioflip_logo_128x128.png ddl/

      Invalid AIR file

      The files are all there:
      davis@kafka:~/git/biblioflip/biblioflip-ui$ ls -alh bin-debug/
      total 14M
      drwxr-xr-x  3 davis davis 4.0K 2010-10-15 02:03 .
      drwxr-xr-x 11 davis davis 4.0K 2010-10-15 01:43 ..
      -rw-r--r--  1 davis davis 4.1K 2010-10-15 01:43 biblioflip_logo_128x128.png
      -rw-r--r--  1 davis davis  481 2010-10-15 01:43 biblioflip_logo_16x16.png
      -rw-r--r--  1 davis davis  879 2010-10-15 01:43 biblioflip_logo_32x32.png
      -rw-r--r--  1 davis davis 2.1K 2010-10-15 01:43 biblioflip_logo_48x48.png
      -rw-r--r--  1 davis davis 1.1M 2010-10-15 02:05 biblioflip.swf
      -rw-r--r--  1 davis davis  13M 2010-10-15 02:03 biblioflip-webapp.jar
      drwxr-xr-x  2 davis davis 4.0K 2010-10-15 01:43 ddl
      I have no other insight into why this is failing.  This same build file works just fine on both Mac/Windows and I'm creating native installers for those operating systems that work.  Why is it failing on Linux?