3 Replies Latest reply on Jul 19, 2007 6:01 AM by Newsgroup_User

    php, mysql, apache, windows xp

    shinceciokada
      I use the most recent versions of php, apache, mysql and windows xp. And I use Dreamweaver 2004MX.
      I create a very simple index.php and when I preview on a browser, the address becomes like this.
      http://localhost/artgallery/TMP2zjuplef9z.php instead of index.php at the end in the browser address.
      Each time when I preview it, it create random address at the end instead of index.php.
      Why does it create like this? Is there anything I can fix this?
        • 1. Re: php, mysql, apache, windows xp
          Level 7
          Edit/Preferences/Preview in Browser. Uncheck the "create temporary files"
          checkbox and restart Dreamweaver.


          --
          Nancy Gill
          Adobe Community Expert
          Author: Dreamweaver 8 e-book for the DMX Zone
          Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
          Technical Editor: Dreamweaver CS3: The Missing Manual,
          DMX 2004: The Complete Reference, DMX 2004: A Beginner's Guide
          Mastering Macromedia Contribute
          Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web Development

          "shinceciokada" <webforumsuser@macromedia.com> wrote in message
          news:f7mm6c$ai7$1@forums.macromedia.com...
          >I use the most recent versions of php, apache, mysql and windows xp. And I
          >use
          > Dreamweaver 2004MX.
          > I create a very simple index.php and when I preview on a browser, the
          > address
          > becomes like this.
          > http://localhost/artgallery/TMP2zjuplef9z.php instead of index.php at the
          > end
          > in the browser address.
          > Each time when I preview it, it create random address at the end instead
          > of
          > index.php.
          > Why does it create like this? Is there anything I can fix this?
          >
          >


          • 2. Re: php, mysql, apache, windows xp
            Level 7
            However, doing this will prevent your root relative links (if any), and
            server-side includes (I think) from rendering properly in preview.

            My suggestion would be to ignore it for you local previews. It's how DW
            works.

            --
            Murray --- ICQ 71997575
            Adobe Community Expert
            (If you *MUST* email me, don't LAUGH when you do so!)
            ==================
            http://www.dreamweavermx-templates.com - Template Triage!
            http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
            http://www.dwfaq.com - DW FAQs, Tutorials & Resources
            http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
            ==================


            "Nancy - Adobe Comm. Expert" <nancy@webwish.com> wrote in message
            news:f7mq70$esk$1@forums.macromedia.com...
            > Edit/Preferences/Preview in Browser. Uncheck the "create temporary files"
            > checkbox and restart Dreamweaver.
            >
            >
            > --
            > Nancy Gill
            > Adobe Community Expert
            > Author: Dreamweaver 8 e-book for the DMX Zone
            > Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
            > Technical Editor: Dreamweaver CS3: The Missing Manual,
            > DMX 2004: The Complete Reference, DMX 2004: A Beginner's Guide
            > Mastering Macromedia Contribute
            > Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web
            > Development
            >
            > "shinceciokada" <webforumsuser@macromedia.com> wrote in message
            > news:f7mm6c$ai7$1@forums.macromedia.com...
            >>I use the most recent versions of php, apache, mysql and windows xp. And I
            >>use
            >> Dreamweaver 2004MX.
            >> I create a very simple index.php and when I preview on a browser, the
            >> address
            >> becomes like this.
            >> http://localhost/artgallery/TMP2zjuplef9z.php instead of index.php at the
            >> end
            >> in the browser address.
            >> Each time when I preview it, it create random address at the end instead
            >> of
            >> index.php.
            >> Why does it create like this? Is there anything I can fix this?
            >>
            >>
            >
            >


            • 3. Re: php, mysql, apache, windows xp
              Level 7
              Murray *ACE* wrote:
              > However, doing this will prevent your root relative links (if any), and
              > server-side includes (I think) from rendering properly in preview.

              This applies only if you have selected root relative links in the site
              definition. Using root-relative links in PHP sites can cause a lot of
              problems for the unwary. I would recommend using document-relative links
              unless you really know what you're doing.

              --
              David Powers, Adobe Community Expert
              Author, "Foundation PHP for Dreamweaver 8" (friends of ED)
              Author, "PHP Solutions" (friends of ED)
              http://foundationphp.com/