6 Replies Latest reply on Oct 26, 2010 2:03 PM by Todd_Kopriva

    Relink Illustrator files problem

    TMurison

      I've never seen anything like this:

       

      I have a project created in CS4 (unknown exact version) outside my company and I need to continue work on the project.  Project and assets shipped over on a firewire drive.  Almost 400GB of stuff, so just to verify before I start copying to my system I open the project (in CS4) directly from drive and quickly check things out.  Everything seems okay.  Copy drive contents.  Next day I open the project in CS5 on my system.  CS5 informs me my footage is missing so I relink one file and AE finds everything else.  However, almost all (but not every) Illustrator file is relinked as the 'wrong size'.  That's the best I can describe it.  Masking done on the ai files is completely wrong, animations don't work because of this, etc.  I though, okay I'll try opening in CS4.  Same deal.  So I spun up the firewire drive and opened the project from there to make sure I wasn't crazy.  Everything is fine.  ?  So I'm crazy.

       

      My next thought was that the import settings I last used to import ai files as a composition must be hosing things up.  But I get no choice when relinking, so I imported one layered file from another project as a comp using retain layer sizes then relinking (didn't fix) and then imported as comp using document size (didn't fix). I tried relinking to the files directly off the firewire drive and that didn't work in either CS4 or CS5.

       

      What's the MOST puzzling to me is that if I open the original CS4 project off of the firewire drive and relink any one .ai file to THE SAME files on my system's drive (in the same directory structure, etc.) the problem appears.  If I open the original project off the firewire drive in CS5, the project is fine too but I same probelm with relinking to .ai files on my system.  So for now I'm working off of the firewire drive.  Not ideal for sure but I'm getting by.

       

      I would entertain any thoughts anyone wants to offer up.  Maybe I've missed something obvious, but I've done similar projects plenty of times and not seen any issues like this.

       

      More details:

       

      Mac 10.6.4   2 x 2.8GHz Quad

      6GB RAM

      CS4 9.0.2.42

      CS5 10.0.1.19

      Client's Firewire drive: LaCie 1TB external

      System storage location: Fibre channel shared RAID

      Project has ProRes 422 HQ 1920 x 1080 29.97 QT footage and Illustrator files as assets

      Don't know how or what version of .ai files were created in

      Illustrator files have been masked/animated so when I relink files on my system as above, the masks are all wrong vs. the ai file dimensions

      Every Illustrator file I've opened is a single layer document (there are hundreds, not tried EVERY one, but every one in project is single layer, not comp

      Importing as Composition with retain layer sizes OR document size makes no difference in this issue

       

      Thanks in advance,

       

      -Troy Murison

      Seattle, WA