20 Replies Latest reply on Nov 10, 2010 2:28 PM by Peter Grainge

    Wierd characters iso-8859-1   UTF-8  RH8

    dh2help

      I have 10 projects that all work fine, except this one. On the top of every page the following appears:   , I get the same in IE and FF.  So I deleted my build and created a fresh blank (only welcome topic) project in RH8, same result.  How can they all work except this one, and it's a new blank fresh project?

       

      Sorry if this has been answered before I have read alot of threads and I can't seem to find an answer that works for this project.

       

      Here is what appears on the top of the welcome topic:

       

      The coding a the top of my topic before compiling:

      <?xml version="1.0" encoding="utf-8" ?>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml">
      <head>
      <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
      <meta name="generator" content="Adobe RoboHelp 8" />

        • 1. Re: Wierd characters iso-8859-1   UTF-8  RH8
          Willam van Weelden Adobe Community Professional & MVP

          Hi,

           

          You're seeing the Byte Order Mark (BOM).

          See this post: http://forums.adobe.com/message/3189093#3189093

           

          Please post back if the other post isn't helpful.

           

          Greet,

           

          Willam

          • 2. Re: Wierd characters iso-8859-1   UTF-8  RH8
            dh2help Level 1

            Ok, so back when I was using RH5 it created HTML pages now with RH8 it creates XHTML pages and thats why all of my old projects work and this new project doesn't, from what I have been reading.  Correct?

             

            Something to do with the code: <?xml version="1.0" encoding="utf-8" ?> that is automatically generated with each new page by RH8? Find and replace? Any other permanent fixes? Will this happen with every RH8 project I create? If so, I want my money back because I am going to have to go back to RH5.

            • 3. Re: Wierd characters iso-8859-1   UTF-8  RH8
              Peter Grainge Adobe Community Professional (Moderator)

              It sounds like your server is not set up for UTF-8. You have mentioned ISO8859-1 in your title but not in your post. Is the problem the server setting and can you not change it?

               

              There is an option to output as HTML as well. See Tools > Options.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

              @petergrainge

              • 4. Re: Wierd characters iso-8859-1   UTF-8  RH8
                dh2help Level 1

                It can't be the server since the other RH Projects work on the server. I am trying your Tools > Options > General tab > Conver RoboHelp edited topics to Html suggestion. I'll let you know if it works.

                • 5. Re: Wierd characters iso-8859-1   UTF-8  RH8
                  Peter Grainge Adobe Community Professional (Moderator)

                  Do the others have that code in them?

                   


                  See www.grainge.org for RoboHelp and Authoring tips

                   

                  @petergrainge

                  • 6. Re: Wierd characters iso-8859-1   UTF-8  RH8
                    dh2help Level 1

                    Well, the HTML option didn't work, I was so hopeful.  Anyways,  this is what the code looks like on the top of every page when using the HTML option:

                     

                    &#239;&#187;&#191;
                    <html>
                    <head>
                    


                    So removing all of the other meta tags didn't help any. Note that the numbers (#239 etc) display as:  .  It doesn't display when I open the application on my desktop and rememeber it doesn't display for any other projects.

                    • 7. Re: Wierd characters iso-8859-1   UTF-8  RH8
                      Peter Grainge Adobe Community Professional (Moderator)

                      Let's step back a bit.

                       

                      You said at the beginning that the BOM characters appear on the project that is not working. Do you mean you see those in the browser or just in the code? If it is in the browser, please insert a screenshot using the camera icon above.

                       

                      Do you also see this problem in the generated help on your hard disk?

                       

                      I asked earlier why you had included ISO-8859-1 in the title. I ask again.

                       

                      Finally, do you get the problem with the sample projects.

                       


                      See www.grainge.org for RoboHelp and Authoring tips

                       

                      @petergrainge

                      • 8. Re: Wierd characters iso-8859-1   UTF-8  RH8
                        dh2help Level 1

                        char.gif

                        Regarding the iso-8859-1, I've seen that in other posts regarding this problem.

                         

                        No the characters do not appear in the browser when I run it on my desktop. Once again you would think server, but the other projects work on the same server. I just uploaded an older version created with RH5 and it still works properly on the server. Worst comes to worst I will recreate my changes again in the older build. But it looks like RH8 will never create new projects that will work. Only RH5 converted to RH8 work. Figure that one out.

                         

                        New info, the plot is thickening...I found this program called Textpad that displays the hidden characters () in the code.  What I learned was that the minute you open an RH5 project in RH8 it converts the pages and adds the characters to every page,   I compared 5 pages of rh5 to rh8.

                         

                        Also an interesting fact is that this is the only project I have created by importing the RH5 topics.  All other projects were created in RH5 and then opened/converted into RH8.  Also, the new blank test project I created in RH8 didn't work.

                         

                        Another thing I did to troubleshoot. I opened all of the pages and removed the characters by saving them in Notepad++  (Encoding > Convert to UTF-8 without BOM).  They look fine in Textpad but when you look at the generated files the hidden characters are there.

                         

                        But back to the part where all projects, including other projects that work have these hidden characters....

                        • 9. Re: Wierd characters iso-8859-1   UTF-8  RH8
                          Peter Grainge Adobe Community Professional (Moderator)

                          Once again I do think it is the server. All projects work fine locally, one does not on the server. There is clearly something that the server does not like about the one project and that is the BOM. Why it is only affecting this project is less clear. Have you spoken to your IT people about this as that is a matter they will likely understand better.

                           

                          Did you try the samples as suggested?

                           


                          See www.grainge.org for RoboHelp and Authoring tips

                           

                          @petergrainge

                          • 10. Re: Wierd characters iso-8859-1   UTF-8  RH8
                            Willam van Weelden Adobe Community Professional & MVP

                            Hi,

                             

                            The BOM are used to determine how the file is encoded. It has nothing to do with the xml declaration. Hence Peter's suggestions about your servers not being configured correctly.

                             

                            If you want to strip the BOM, follow the links of my previous post. They point to a site with instructions to mass strip the BOM from files.

                             

                            Greet,

                             

                            Willam

                            • 11. Re: Wierd characters iso-8859-1   UTF-8  RH8
                              dh2help Level 1

                              Hi,

                               

                              The program Mind Pioneer per WVW really is the best program I tried for stipping/changing UTF-8/BOM:
                              http://www.mind-pioneer.com/services/633_Replace_text_in_multiple_files.html

                               

                              I found that the topics and other RH build files have the BOM in them. Something in the stipping messed up the way the TOC displays, it moved it right about 5 char.  But I tested it anyways and it still doesn't work. We now have the IT people looking into it.  I'll let you know if we find a fix. I really don't want to go back to RH5.  Thank you for all of your suggestions.

                              • 12. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                Peter Grainge Adobe Community Professional (Moderator)

                                If your IT people can confirm it is the encoding that is causing the problem and if they cannot / will not change it, email me with a link to this topic. There is an Adobe provided file that will encode to other settings.

                                 


                                See www.grainge.org for RoboHelp and Authoring tips

                                 

                                @petergrainge

                                • 13. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                  dh2help Level 1

                                  Peter, per your last thread..

                                   

                                  If your IT people can confirm it is the encoding that is causing the problem and if they cannot / will not change it, email me with a link to this topic. There is an Adobe provided file that will encode to other settings.

                                  ================================

                                  What do you need to know?  How can they confirm it is an encoding problem?

                                   

                                  Our configuration is:

                                  Operating System - AIX V5.3
                                  Database - Sybase 12.5.3
                                  Language - IBM Java V1.5.0 SR4
                                  Application Server - Weblogic 9.2

                                  • 14. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                    Peter Grainge Adobe Community Professional (Moderator)

                                    By advising you whether the server is set up to support UTF-8.

                                     


                                    See www.grainge.org for RoboHelp and Authoring tips

                                     

                                    @petergrainge

                                    • 15. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                      dh2help Level 1

                                      Regarding whether the server is setup to handle UTF-8 they didn't configure anything.   At this point I am going to have to switch back to 5 or something else because now RH8 is crashing and not able to read the cpd files of my 10+ projects, it's been 60 days, I wonder if I can still get a refund?  Now I will have to strip all of the files and recreate the projects.  Great fun. Not happy. Why does Adobe have to continually add code to projects for us?

                                       

                                      Anyways my problem..I read something interesting about BOM (Byte Order Mark) in wikipedia.org.  It says:

                                       

                                      "While Unicode standard allows BOM in UTF-8 [2], it does not require or recommend it"....and

                                       

                                      • 16. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                        Peter Grainge Adobe Community Professional (Moderator)

                                        Unless I am misunderstanding you, your server has not been set up to handle UTF-8 and you are complaining it doesn't handle it. Well no it wouldn't.

                                         

                                        As to why Adobe changed this, I believe it was to enable the support of more languages.

                                         

                                        Other users have either got their IT people to support UTF-8 or used a tool that encodes to whatever the server is set up for. However, you have to know what it is set up for and that has not yet been established.

                                         

                                        This really does look to be a server problem and it is not causing this headache for others so I would be surprised to see Adobe give a refund at this stage.

                                         

                                        Going back is going to be a heck of a task so my tack would be to work with IT and get one of the sample projects working on the server, they are known quantities.

                                         

                                        The projects were not crashing before so what has changed. They are run locally? Have you tried deleting the CPD files? Have you made changes to the topics in an effort to fix this problem?

                                         


                                        See www.grainge.org for RoboHelp and Authoring tips

                                         

                                        @petergrainge

                                        • 17. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                          dh2help Level 1

                                          I should clairfy, it's acutally not the UTF-8 that's the problem, its the hidden BOM thats the problem. And yes, stripping out the hidden BOM does temporarily fix the problem.  In what version was the UTF-8 information added?  Maybe I could get V7 to work?

                                          • 18. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                            Peter Grainge Adobe Community Professional (Moderator)

                                            Sorry to tell you but I think it was in RoboHelp 7 so that will not help you.

                                             

                                            At one point you had nine projects working and this rogue.

                                             

                                            Can you at least get back to that stage?

                                             

                                            You did say this is the only project where you imported rather than upgrading. Any reason you cannot upgrade rather than import?

                                             

                                            Clutching at straws but could there be something different about the folder on the server for this project?

                                             

                                            I encountered a different BOM problem with FF and that turned out to be server related. I don't think it is the same thing but maybe something in the text might ring a bell with your IT people. I've highlighted one point. Doubt it could be that simple but...

                                             

                                            ****************************************

                                             

                                             

                                            This is what I was advised by the company hosting my site.

                                             

                                            "I would therefore conclude that the solution to this problem (on Linux systems running Apache) is to add the AddDefaultCharset utf-8 directive to either the Apache config or the site .htaccess file. The advantage of the latter is that it only affects individual sites. The default Apache character set is taken from the locale file on Linux and defaults to iso-8859-1. It is the conflict between the Apache header with iso-8859-1 and the page character set of utf-8 that obviously causes Firefox a problem."

                                             

                                            In a forum post Chrissy_Tissy added

                                            My machine is Windows, but this fix still worked  - some notes about making the fix visible:

                                            1. Do the fix itself (httpd.conf: AddDefaultCharset utf-8).

                                            2. Restart the box to apply the fix.

                                            3. Once the box is restarted, clear your cache in FireFox to make sure you don't continue to see the cached file.

                                            Once all this is done you will see the output content as expected.

                                             

                                             


                                            See www.grainge.org for RoboHelp and Authoring tips

                                             

                                            @petergrainge

                                            • 19. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                              dh2help Level 1

                                              Since we're not using Apache, no htaccess file.  That was one of the first things I thought to look at, oh well.

                                               

                                              The fix I am going to use was just provided to me by Adobe it's called: RoboHelp 8 Encoder Tool. It's fast and easy to use. Select the webhelp output folder, UTF-8 and clear the Include BOM check box. Apparently I'm not the only one having problems.

                                              • 20. Re: Wierd characters iso-8859-1   UTF-8  RH8
                                                Peter Grainge Adobe Community Professional (Moderator)

                                                That is the file I mentioned on 25 Oct but you were adamant that it was not the encoding.

                                                 


                                                See www.grainge.org for RoboHelp and Authoring tips

                                                 

                                                @petergrainge