5 Replies Latest reply on Oct 24, 2010 7:34 AM by Mylenium

    Recently installed AE CS 4 on new MacPro and it keeps crashing

    Mortisfilm Level 1

      Hello everyone,

       

      I recently replaced an ancient Mac PowerPC G5 running AE 6.5 with a new MacPror running AE CS4, and as I've been trying to get myself up to speed with this new (to me, anyway) version of AfterEffects, I've had lots of problems with the software freezing, resulting in an endless spinning color wheel (I know we've all been there, but since everything is so brand new, this is driving me even more insane).

       

      I've been working with projects created in AE 6.5, which take a long time to convert to AE CS4, but even when I reduce the project size to only a few files (and remove all my 3rd party effects) I can't work more than a few minutes without the software crashing. Even something as simple as renaming a composition or creating a new folder might cause AE CS4 to freeze up.

       

      I'm hoping the forum can provide me with some tips, or at least set me on the right path so my new computer and I can get along.

       

      Here are some technical details -- but I'm sure this is just the tip of the iceberg, please let me know if you need additional information to help me troubleshoot:

       

      Computer:

       

      Intel MacPro

      Processor: 2 x 2.66 GHz 6-Core Intel Xeon

      Memory: 14 GB 1333 MHz DDR3

       

      AfterEffects:

       

      CS4 v9.0.3

       

      Preferences:

       

      Levels of Undo: 8

      Synch Time: Off

      Enable Disk Cache: On (Maximum Disk Cache Size: 2000 MB)

      RAM to leave for other applications: 6 GB

      Multiprocessing: Off

       

      Thanks and hope all is well,

       

      Dan

        • 1. Re: Recently installed AE CS 4 on new MacPro and it keeps crashing
          Todd_Kopriva Level 8

          Are other applications working OK on this computer?

           

          Do you have OpenGL rendering turned on? If so, turn it off. See this document: http://kb2.adobe.com/cps/405/kb405948.html

           

          What version of Mac OSX are you running?

          • 2. Re: Recently installed AE CS 4 on new MacPro and it keeps crashing
            Mortisfilm Level 1

            Hi Todd,

             

            Thanks so much for the quick response.

             

            My other applications are running smoothly. I'm using Snow Leopard version 10.6.4.

             

            I'll give the document you linked to a read and report back once I've disabled OpenGL. Here's the info that comes up when I click on "OpenGL Information":

             

            Vendor: ATI Technologies Inc.

            Renderer: ATI Radeon HD 5870 OpenGL Engine

            Version: 2.1 ATI-1.6.20

             

            Settings: Texture Memory: 1006 MB

             

            More Accurate Capabilities

            All Blending Modes: Supported

            Adjustment Layers: Supported

            Track Mattes: Supported

            Accelerated Effects: Supported

            Antialiasing: Supported

            Motion Blur: Supported

             

            Capabilities

            Lights: Supported

            Shadows: Supported

             

            Just to make sure I'm doing this right, in my 'Previews' prefs, I currently do have Enable OpenGL switched to "on", with Enable Adaptive Resolution with OpenGL and Accelerate Effects using OpenGL (when possible) switched to "on" as well. To turn off OpenGL rendering, all I do is turn the Enable OpenGL switch to "off", correct?

             

            Thanks,

             

            Dan

            • 3. Re: Recently installed AE CS 4 on new MacPro and it keeps crashing
              Mortisfilm Level 1

              Hi all,

               

              AfterEffects is running smoother since I turned off OpenGL -- thanks so much for the tip.

               

              Howerver, I'm still having some performance issues.

               

              When I preview a 1280x720 composition at 'full' resolution (using a project originally created in AE 6.5 on my old PowerPC G5 Mac), I get an 'unable to allocate space for a 9000x6000 image buffer..." warning. The source files for this project are large, but I was able to preview this project at 'full' resolution on my old computer (it took a really, really long time to generate this preview, but it did ultimately work).

               

              I was expecting my new machine would be able to handle a project of this type with ease, and I'm hoping I just need to make some adjustments (to my preferences, perhaps...?)

               

              It also takes a really long time for projects to open -- the program seems to crawl to a halt when the project is 95% loaded, then I wait a few minutes for it to finish loading.

               

              And when I open up a new composition (or jump to a new point in my timeline), I get a long, colored-spinwheel delay.

               

              Any suggestions would be greatly appreciated.

               

              Dan

              • 4. Re: Recently installed AE CS 4 on new MacPro and it keeps crashing
                Mortisfilm Level 1

                Still hoping for some help or advice in regards to this issue. Whenever I import a large Photoshop file -- say anything over 6000x6000 pixels (with about 10 layers, no layer effects) to work with using AE CS 3 or CS 4, I get 'unable to allocate space for a ... image buffer..." warning.

                 

                These are files that I am able to work with on my old computer in 6.5, so I'm guessing there's some kind of preference or setup that I'm missing, as my new machine should definitely be able to handle these projects with ease.

                 

                Any suggestions? Please let me know if you need any more info, I'm eager to get this resolved so I can move on with my work.

                 

                Dan

                • 5. Re: Recently installed AE CS 4 on new MacPro and it keeps crashing
                  Mylenium Most Valuable Participant

                  These are files that I am able to work with on my old computer in 6.5, so I'm guessing there's some kind of preference or setup that I'm missing, as my new machine should definitely be able to handle these projects with ease.

                   

                  Not necessarily. Newer versions of AE already have a much larger baseline memory footprint, leaving less resources. That combined with you still using a 32 bit version that can only use so much RAM to begin with may already be enough to make it not work... And possibly Apple having lost control over OSX is part of the problem, too. In any case, you should simply try CS5 and consider upgrading, if you regularly work with such large stuff...

                   

                  Mylenium