11 Replies Latest reply on Jul 23, 2007 1:29 PM by kglad

    Flash Newbie needs help with Movie Clips/Action Scripting

    trib_caroline
      Hi -

      I'm having a problem with my movie clips playing simultaneously and cannot, for the life of me, figure out what I have done wrong. I'm new to flash, so I may have set something up incorrectly, but here's what I have so far:

      11 layers, total: 1 layer with 10 control buttons, each button with the following actionscript:


      on (release) {
      gotoAndPlay(85);
      }


      Where the number changes in relation to which keyframe the next movie is on.

      I have 10 movies, total, but they are only movie clips, essentially photo slide shows with audio, made all in the library.

      The problem happens when I click on the second or third button. Not only does the movie that I have selected begin to play, but all of the previous clips do as well, so it all sounds quite garbled. I don't know what I am missing in the action script, as my Action Layer has a stop command on it at each keyframe where there is a new clip to play.

      I have tried to add a stopAllSounds command, but I'm afraid that doesn't do anything because it is not a "sound file" per se, playing in the timeline.

      I'm at the end of my rope and really need some help in figuring this one out. My project is hanging in the balance on this, as I have scripted everything else correctly and it runs beautifully.

      Please help!

      Thanks,
      Caroline