6 Replies Latest reply on Dec 16, 2010 5:17 AM by tntecho

    Text changes

    tntecho

      Hi,

       

      Im copying and pasting into a text box within catalyst.  ( its a lot of text so im having a scroll bar )

       

      anyway it pastes fine but when i make any changes to the text as soon as i click off the box it reverts back to what i pasted in originally.

       

      anyone come across this? ive tried pasting from different applications but no luck. when i create a text box and add text myself its just fine and the changes i make stay.

       

      i should add this is the trial catalyst version - could that be it?

       

      any help please, thanks

        • 1. Re: Text changes
          Peter Flynn (Adobe) Adobe Employee

          Hi tntechno,

           

          We're not familiar with this problem.  Do you have this problem with all text objects in Catalyst?  What happens if you just click in a blank area with the text tool and then paste?  (This should create a new, blank Point Text object that you can paste into).

           

          Also, you may want to try several different ways of pasting -- Edit menu, context menu, or keyboard shortcut.  Please let us know if you're seeing any differences between those.

           

          - Peter

          • 2. Re: Text changes
            tntecho Level 1

            Hi, thanks for your reply.  Im still having problems with text boxes.

            Its strange sometimes it will work but mainly not. Even when I type the text in manually and not copying and pasting. Ive even creating a blank page with just a text box and can get the problem. 
            I type text into the text box and as soon as I click off the text box the text dissapears leaving me with just a empty text box.
            Or on the odd occasion I have text in a box, I make changes to it then as soon as I click off the text goes back to the way it was.
            any help please, many thanks

            • 3. Re: Text changes
              AirBeagle1

              I'm having the exact same issue... it's driving me batty.  I can type in the text, I can paste it in, I can keyboard shortcut it in -- whatever method I use, it looks great until I click outside the text box, then it all reverts back to its previous state.

               

              OS is Win7 64-bit

               

              This is the full paid version as part of the CS5 Master Suite.

               

               

              (I should note that if I run the project, the text changes show up, but when looking at it in Flash Catalyst -- nothing.

              • 4. Re: Text changes
                Karl Decker

                Hello… I was having this same problem and here is what I learned. I created all my text in Illustrator but I assume it would hold true for any "other" program in which you create text besides Catalyst itself. Most other programs have a large number of options available for formatting text. Usually these options are for final output to print and include such options as paragraph spacing, leading, tracking or kerning, hard returns, soft returns etc… Not all these options are built in to Catalyst. I am not sure how Catalyst interprets some of these more obscure options such as varying baseline shifts to get a © mark exactly where you want it or tabs… In other words all the formatting options that as a designer you finesse to get the typography exactly how you want it to look. I originally had my text blocks set up in two column format… sometimes with the first column left blank which, for me, is what caused the text to change in appearance between editing mode and how it ultimately appeared on screen. My suggestion would be to remove all formatting, ALL formatting from your text so that it is a single column of text and use only those options available in Catalyst to format. This is very similar to working on a print project and using Word documents imported into InDesign where you tell the originator of the Word file to save it out as "text only with line breaks" which removes all those nasty tabs. I hope this helps.

                 

                Karl

                • 5. Re: Text changes
                  AirBeagle1 Level 1

                  Excellent thought... unfortunately this happens with text I create directly in Catalyst as well, even single line, standard characters only.  When I publish the file, the characters are there, but I don't see them in Flash Catalyst itself (which makes lining things up, editing, etc. quite difficult).

                   

                  Appreciate the help!

                  • 6. Re: Text changes
                    tntecho Level 1

                    Thanks for the replies, least I know im not alone in having this problem.

                     

                    I didn't actually know that when you run the file the text will appear so thats something I suppose, but as you said its not very helpful when you are trying to edit.