6 Replies Latest reply on Jan 7, 2011 12:08 PM by me04015

    WSDL won't load from mobile device

    IFZen Level 1

      Hi everybody,

       

      I started an App for Android with Burrito, based on a SOAP web service.

       

      If I test my App inside Burrito everything go right, WSDL is loaded, methods are called and results shows up.

       

      But for the moment I use packaged App (.apk) on my mobile (HTC Desire), WSDL won't load. App install is OK but when it start no request is sent to my server. I tried to load a crossdomain.xml file at start. I can see the request on it going OK on my Apache server logs but WSDL request is never received. On my mobile, when my App start I got this error message :

       

      "HTTP request error. Unable to load WSDL. If currently online, please verify blah blah blah..."

       

      Does anybody knows what is happening here ?

       

      Thanks for reply,

       

      François, Paris

        • 1. Re: WSDL won't load from mobile device
          chrisp4d

          not sure if its the same thing, but i had a similar problem.  basically when i ran it from the desktop in FB, it worked, but not from the phone.  here was my issue...

           

          when running it locally, my computer is on the same network as my coldfusion server and it works fine on the network.  we have a different url for local and public access (aka had to use the server's IP in the wsdl url).  so basically when i test locally, i had to use the local url but when i compiled it for the phone, i changed the wsdl to use the public IP url.  basically what im saying is make sure your apache server has a public url, or at the very least, an IP you can access outside of your local network.  if not, your wsdl will never resolve because it cant contact the box.  hope this helped.

           

          Chris

          1 person found this helpful
          • 2. Re: WSDL won't load from mobile device
            IFZen Level 1

            Thank you very much Chris ,

             

            I really appreciated your answer and you put me on new rails this morning to track my bug but unfortunately I still cannot load my WSDL :/

             

            I did however some progress :

             

            1. I thought I had problems with crossdomain access so I changed my initialization sequence : first I load an image in the background to check if network access is OK, and it works ! Image loads on the same domain than my web service so it should be ok then... Since image URL is loaded my device can resolve the URI and access my server. My Apache logs showns everything is ok...
            2. ...but no , when I click on a button I initialize my web service access objects (WebServiceWrapper & CallResponder) and I got the same error "HTTP request error / Unable to load WSDL. blah blah blah". Apache log does not show any access attempt for this operation.

             

            If I test my App inside Burrito everything works fine ! I tried to tickle Air with a crossdomain file policy but it just failed my Burrito sessions too, and since sandboxtype is "Application" I should'nt have any trouble with cross-domains access.

             

            So I did two steps forward and something like two steps backward.

             

            Do anybody has any idea or suggestions ?

             

             

            HEEEEEEEEEELLLLLLPPPPP

             

             

            In Burrito nobody hears you crying ?

             

            François

            • 3. Re: WSDL won't load from mobile device
              chrisp4d Level 1

              sorry i forgot to respond to this, whats your wsdl written in?  i know when i have an error in my wsdl (i use coldfusion cfcs for mine) i get that HTTP request error / Unable to load WSDL error if the wsdl is in fact the thing generating the error.  check out your wsdl to make sure its not doing anything server specific as well.

               

              if you dont mind, post your flex code and wsdl code.  since your app is loading your image, its gotta be either some weird code in the wsdl or webservice call in flex is screwy.

               

              Chris

              • 4. Re: WSDL won't load from mobile device
                IFZen Level 1

                Hi Chris,

                 

                Thanks for your interest, you're great, and don't bother for delays, I have myself issues with planning and scalability at the moment

                 

                The SOAP WSDL is here : http://morigami.net:8134/nihongoTango/?wsdl

                 

                If you have some time to try you will find here an archive of my sources : http://morigami.net:8134/nihongoTango/NihongoTango.zip

                 

                It embeds my FB Burrito project directory. I just took off TweenLite libs and code to get a lighter archive.

                 

                Tested on my FB it works just fine, but on device it fails poorly to load WSDL. Too bad.

                 

                To use it just press the Login button, username and password are pre-filled for test purpose.

                 

                On the first page you'll see estupido debuging labels displayed on the bottom part of the screen, they just help me to follow network events. With that you'll see background image loading progress, WSDL & web service access (when it works).

                 

                Again thanks a lot for your interest. I have to admit I am two inches short to drop part of the project (the 'SOAP webservice are great to gain time' part of it). If I can't progress here I will substitue it with classical "SendAndLoad" good old boys. Rawhide !

                 

                François

                • 5. Re: WSDL won't load from mobile device
                  IFZen Level 1

                  Hi again,

                   

                  I tried something completely different. I just created a new project, defined the WebService with FB utilities and bind a text area with one of my SOAP method result. I worked just fine inside FB AND my HTC Desire ! Sweet moment !

                   

                  Something surely went wrong mith my previous project. I will give some time to inquire this bu t the good news is SOAP access works !

                   

                  Thanks again and again for your support.

                   

                  François, Paris

                  • 6. Re: WSDL won't load from mobile device
                    me04015

                    I've run into the same thing

                     

                    Create a new project, connect to a webservice, everything initially works fine both from the air emulator and from the google emulator.

                    Continue to work on and test the project, then all of a sudden it will start returning Unable to load WSDL errors under the google emulator. Still works fine in air when launched from the ide.

                    Tried removing all refrences to the webservice from the project and readding it, still errors under the emulator.

                     

                    Create a brand new project, copy all of the src files over from the previos project, and everything works fine again.